You are viewing a plain text version of this content. The canonical link for it is here.
Posted to pluto-dev@portals.apache.org by "Torsten Dettborn (JIRA)" <ji...@apache.org> on 2007/07/26 08:10:31 UTC

[jira] Created: (PLUTO-398) Update to Rev.21

Update to Rev.21
----------------

                 Key: PLUTO-398
                 URL: https://issues.apache.org/jira/browse/PLUTO-398
             Project: Pluto
          Issue Type: Task
          Components: general
    Affects Versions: 1.1-286-COMPATIBILITY
            Reporter: Torsten Dettborn
             Fix For: 1.1-286-COMPATIBILITY


The main issue is the update to the new Revision 21.
Shared RenderParameter renamed to publicRenderParameter.

This are the changes since the last api update

Draft 21:
---------
- deployment descriptor: changed supported-processing/publishing-event to have subelements name and qname


Draft 20:
---------
- API: 
       rename getWindowId to getWindowID
       CacheControl: defaults are taken from the DD
       removed deprecation of RD.include(RenderReq, renderResp) to avoid always getting deprecation warnings for render
       GenericPortlet: added support for dispatching to wildcard events
       introduced base class for portlet filters: 
- added getPublishingEventQNames, getProcessingEventQNames, getSupportedLocales to PortletConfig
- deployment descriptor: changed supported-processing/publishing-event type from QName to String


Draft 19: (public draft 1)
---------
- removed the setEvents/NamespacedEvents methods
- API: 
    - changed Object to Serializable for event payload
    - ResourceFilte extends PortletFilter
- renamed javax.portlet.includedJSPPortletSessionScope back to javax.portlet.includedPortletSessionScope and extended the scope to servlet session too


Draft 18:
---------
- API: PortletSession.getMap: fixed that values are of type Object and not String[]
- removed some inconsistencies in the RD chapter
- renamed container extension javax.portlet.includedPortletSessionScope to javax.portlet.includedJSPPortletSessionScope
- support for head contributions (addProperty, MimeResponse.MARKUP_HEAD_ELEMENT, PortalContext.MARKUP_HEAD_ELEMENT_SUPPORT)
- API: replaced enumeration with collection in RenderResponse.setNextPossiblePortletModes
- section on character set for resource response
- removed the restriction to set a content type before getting a writer


Draft 17:
---------
- API: renamed setDefaultNamspacedEvents to setDefaultNamespacedEvents
- API: added PortletFilter as superclass for all Portlet filters
- added Namespace response
- API: add PortletRequest: Map getPrivateParameterMap(), Map getPublicParameterMap()
- taglib: copyCurrentRenderParamters:  copies only the private render params, 
          param tag: If the value is an empty value the parameter is removed from the portlet URL.
	  portletSessionMap var renamed to portletSessionScope
	  added portletPreferencesValues as var
- DD: replaced public-render-parameter name with simlar structure as in events: name, qname, alias
      removed caching element and made expiration-cache and cache-scope toplevel elements for portlet
- extend default namespace to public render parameters, API: renamed PortletContext.getDefaultEventNamespace to getDefaultNamespace, DD: renamed event-default-namespace to default-namespace
- added extensible URLs: API: BaseURL: added addProperty, setProperty; taglib: added property element for URLs


Draft 16:
---------
- added RD.include(RenderRequest, RenderResponse) as deprecated again in order to keep binary compatibilty with JSR 168
- fixed bugs in annotation processing in GenericPortlet
- PortletContext: merged getPortletRuntimeOptions and getApplicationRuntimeOptions into getContainerRuntimeOptions

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Closed: (PLUTO-398) Update to Rev.21

Posted by "Torsten Dettborn (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/PLUTO-398?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Torsten Dettborn closed PLUTO-398.
----------------------------------

    Resolution: Fixed

the update to revision 21 is still done

> Update to Rev.21
> ----------------
>
>                 Key: PLUTO-398
>                 URL: https://issues.apache.org/jira/browse/PLUTO-398
>             Project: Pluto
>          Issue Type: Task
>          Components: general
>    Affects Versions: 1.1-286-COMPATIBILITY
>            Reporter: Torsten Dettborn
>             Fix For: 1.1-286-COMPATIBILITY
>
>         Attachments: updateToRev21_260707.patch
>
>
> The main issue is the update to the new Revision 21.
> Shared RenderParameter renamed to publicRenderParameter.
> This are the changes since the last api update
> Draft 21:
> ---------
> - deployment descriptor: changed supported-processing/publishing-event to have subelements name and qname
> Draft 20:
> ---------
> - API: 
>        rename getWindowId to getWindowID
>        CacheControl: defaults are taken from the DD
>        removed deprecation of RD.include(RenderReq, renderResp) to avoid always getting deprecation warnings for render
>        GenericPortlet: added support for dispatching to wildcard events
>        introduced base class for portlet filters: 
> - added getPublishingEventQNames, getProcessingEventQNames, getSupportedLocales to PortletConfig
> - deployment descriptor: changed supported-processing/publishing-event type from QName to String
> Draft 19: (public draft 1)
> ---------
> - removed the setEvents/NamespacedEvents methods
> - API: 
>     - changed Object to Serializable for event payload
>     - ResourceFilte extends PortletFilter
> - renamed javax.portlet.includedJSPPortletSessionScope back to javax.portlet.includedPortletSessionScope and extended the scope to servlet session too
> Draft 18:
> ---------
> - API: PortletSession.getMap: fixed that values are of type Object and not String[]
> - removed some inconsistencies in the RD chapter
> - renamed container extension javax.portlet.includedPortletSessionScope to javax.portlet.includedJSPPortletSessionScope
> - support for head contributions (addProperty, MimeResponse.MARKUP_HEAD_ELEMENT, PortalContext.MARKUP_HEAD_ELEMENT_SUPPORT)
> - API: replaced enumeration with collection in RenderResponse.setNextPossiblePortletModes
> - section on character set for resource response
> - removed the restriction to set a content type before getting a writer
> Draft 17:
> ---------
> - API: renamed setDefaultNamspacedEvents to setDefaultNamespacedEvents
> - API: added PortletFilter as superclass for all Portlet filters
> - added Namespace response
> - API: add PortletRequest: Map getPrivateParameterMap(), Map getPublicParameterMap()
> - taglib: copyCurrentRenderParamters:  copies only the private render params, 
>           param tag: If the value is an empty value the parameter is removed from the portlet URL.
> 	  portletSessionMap var renamed to portletSessionScope
> 	  added portletPreferencesValues as var
> - DD: replaced public-render-parameter name with simlar structure as in events: name, qname, alias
>       removed caching element and made expiration-cache and cache-scope toplevel elements for portlet
> - extend default namespace to public render parameters, API: renamed PortletContext.getDefaultEventNamespace to getDefaultNamespace, DD: renamed event-default-namespace to default-namespace
> - added extensible URLs: API: BaseURL: added addProperty, setProperty; taglib: added property element for URLs
> Draft 16:
> ---------
> - added RD.include(RenderRequest, RenderResponse) as deprecated again in order to keep binary compatibilty with JSR 168
> - fixed bugs in annotation processing in GenericPortlet
> - PortletContext: merged getPortletRuntimeOptions and getApplicationRuntimeOptions into getContainerRuntimeOptions

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (PLUTO-398) Update to Rev.21

Posted by "Torsten Dettborn (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/PLUTO-398?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Torsten Dettborn updated PLUTO-398:
-----------------------------------

    Attachment: updateToRev21_260707.patch

Patch for updating to Revision 21

> Update to Rev.21
> ----------------
>
>                 Key: PLUTO-398
>                 URL: https://issues.apache.org/jira/browse/PLUTO-398
>             Project: Pluto
>          Issue Type: Task
>          Components: general
>    Affects Versions: 1.1-286-COMPATIBILITY
>            Reporter: Torsten Dettborn
>             Fix For: 1.1-286-COMPATIBILITY
>
>         Attachments: updateToRev21_260707.patch
>
>
> The main issue is the update to the new Revision 21.
> Shared RenderParameter renamed to publicRenderParameter.
> This are the changes since the last api update
> Draft 21:
> ---------
> - deployment descriptor: changed supported-processing/publishing-event to have subelements name and qname
> Draft 20:
> ---------
> - API: 
>        rename getWindowId to getWindowID
>        CacheControl: defaults are taken from the DD
>        removed deprecation of RD.include(RenderReq, renderResp) to avoid always getting deprecation warnings for render
>        GenericPortlet: added support for dispatching to wildcard events
>        introduced base class for portlet filters: 
> - added getPublishingEventQNames, getProcessingEventQNames, getSupportedLocales to PortletConfig
> - deployment descriptor: changed supported-processing/publishing-event type from QName to String
> Draft 19: (public draft 1)
> ---------
> - removed the setEvents/NamespacedEvents methods
> - API: 
>     - changed Object to Serializable for event payload
>     - ResourceFilte extends PortletFilter
> - renamed javax.portlet.includedJSPPortletSessionScope back to javax.portlet.includedPortletSessionScope and extended the scope to servlet session too
> Draft 18:
> ---------
> - API: PortletSession.getMap: fixed that values are of type Object and not String[]
> - removed some inconsistencies in the RD chapter
> - renamed container extension javax.portlet.includedPortletSessionScope to javax.portlet.includedJSPPortletSessionScope
> - support for head contributions (addProperty, MimeResponse.MARKUP_HEAD_ELEMENT, PortalContext.MARKUP_HEAD_ELEMENT_SUPPORT)
> - API: replaced enumeration with collection in RenderResponse.setNextPossiblePortletModes
> - section on character set for resource response
> - removed the restriction to set a content type before getting a writer
> Draft 17:
> ---------
> - API: renamed setDefaultNamspacedEvents to setDefaultNamespacedEvents
> - API: added PortletFilter as superclass for all Portlet filters
> - added Namespace response
> - API: add PortletRequest: Map getPrivateParameterMap(), Map getPublicParameterMap()
> - taglib: copyCurrentRenderParamters:  copies only the private render params, 
>           param tag: If the value is an empty value the parameter is removed from the portlet URL.
> 	  portletSessionMap var renamed to portletSessionScope
> 	  added portletPreferencesValues as var
> - DD: replaced public-render-parameter name with simlar structure as in events: name, qname, alias
>       removed caching element and made expiration-cache and cache-scope toplevel elements for portlet
> - extend default namespace to public render parameters, API: renamed PortletContext.getDefaultEventNamespace to getDefaultNamespace, DD: renamed event-default-namespace to default-namespace
> - added extensible URLs: API: BaseURL: added addProperty, setProperty; taglib: added property element for URLs
> Draft 16:
> ---------
> - added RD.include(RenderRequest, RenderResponse) as deprecated again in order to keep binary compatibilty with JSR 168
> - fixed bugs in annotation processing in GenericPortlet
> - PortletContext: merged getPortletRuntimeOptions and getApplicationRuntimeOptions into getContainerRuntimeOptions

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (PLUTO-398) Update to Rev.21

Posted by "Ulrich Küster (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/PLUTO-398?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12515701 ] 

Ulrich Küster commented on PLUTO-398:
-------------------------------------

The patch "updateToRev21_260707.patch" has been committed, the new revision number is 559761.


> Update to Rev.21
> ----------------
>
>                 Key: PLUTO-398
>                 URL: https://issues.apache.org/jira/browse/PLUTO-398
>             Project: Pluto
>          Issue Type: Task
>          Components: general
>    Affects Versions: 1.1-286-COMPATIBILITY
>            Reporter: Torsten Dettborn
>             Fix For: 1.1-286-COMPATIBILITY
>
>         Attachments: updateToRev21_260707.patch
>
>
> The main issue is the update to the new Revision 21.
> Shared RenderParameter renamed to publicRenderParameter.
> This are the changes since the last api update
> Draft 21:
> ---------
> - deployment descriptor: changed supported-processing/publishing-event to have subelements name and qname
> Draft 20:
> ---------
> - API: 
>        rename getWindowId to getWindowID
>        CacheControl: defaults are taken from the DD
>        removed deprecation of RD.include(RenderReq, renderResp) to avoid always getting deprecation warnings for render
>        GenericPortlet: added support for dispatching to wildcard events
>        introduced base class for portlet filters: 
> - added getPublishingEventQNames, getProcessingEventQNames, getSupportedLocales to PortletConfig
> - deployment descriptor: changed supported-processing/publishing-event type from QName to String
> Draft 19: (public draft 1)
> ---------
> - removed the setEvents/NamespacedEvents methods
> - API: 
>     - changed Object to Serializable for event payload
>     - ResourceFilte extends PortletFilter
> - renamed javax.portlet.includedJSPPortletSessionScope back to javax.portlet.includedPortletSessionScope and extended the scope to servlet session too
> Draft 18:
> ---------
> - API: PortletSession.getMap: fixed that values are of type Object and not String[]
> - removed some inconsistencies in the RD chapter
> - renamed container extension javax.portlet.includedPortletSessionScope to javax.portlet.includedJSPPortletSessionScope
> - support for head contributions (addProperty, MimeResponse.MARKUP_HEAD_ELEMENT, PortalContext.MARKUP_HEAD_ELEMENT_SUPPORT)
> - API: replaced enumeration with collection in RenderResponse.setNextPossiblePortletModes
> - section on character set for resource response
> - removed the restriction to set a content type before getting a writer
> Draft 17:
> ---------
> - API: renamed setDefaultNamspacedEvents to setDefaultNamespacedEvents
> - API: added PortletFilter as superclass for all Portlet filters
> - added Namespace response
> - API: add PortletRequest: Map getPrivateParameterMap(), Map getPublicParameterMap()
> - taglib: copyCurrentRenderParamters:  copies only the private render params, 
>           param tag: If the value is an empty value the parameter is removed from the portlet URL.
> 	  portletSessionMap var renamed to portletSessionScope
> 	  added portletPreferencesValues as var
> - DD: replaced public-render-parameter name with simlar structure as in events: name, qname, alias
>       removed caching element and made expiration-cache and cache-scope toplevel elements for portlet
> - extend default namespace to public render parameters, API: renamed PortletContext.getDefaultEventNamespace to getDefaultNamespace, DD: renamed event-default-namespace to default-namespace
> - added extensible URLs: API: BaseURL: added addProperty, setProperty; taglib: added property element for URLs
> Draft 16:
> ---------
> - added RD.include(RenderRequest, RenderResponse) as deprecated again in order to keep binary compatibilty with JSR 168
> - fixed bugs in annotation processing in GenericPortlet
> - PortletContext: merged getPortletRuntimeOptions and getApplicationRuntimeOptions into getContainerRuntimeOptions

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.