You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@qpid.apache.org by Alan Conway <ac...@redhat.com> on 2016/09/23 15:33:23 UTC
ctest nit: rename cpp and go tests.
I'd like to rename the C++ and Go tests to use "-" instead of "_" so
they are consistent with the other tests. This is my fault, I wasn't
paying attention when I added the tests. The original tests are like:
� Test��#2: python-test
� Test��#5: ruby-spec-test
� Test #16: c-object-tests
The offending tests are like:
� Test��#6: cpp_codec_test
� Test #25: go_example_electron_test
I want to rename them as cpp-codec-test, go-example-electron-test etc.
Only impact is if you use `ctest -R` to run tests selectively.
Any objection? Silence is consent...
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org
Re: ctest nit: rename cpp and go tests.
Posted by Justin Ross <ju...@gmail.com>.
Yes, please.
On Fri, Sep 23, 2016 at 8:33 AM, Alan Conway <ac...@redhat.com> wrote:
> I'd like to rename the C++ and Go tests to use "-" instead of "_" so
> they are consistent with the other tests. This is my fault, I wasn't
> paying attention when I added the tests. The original tests are like:
>
> Test #2: python-test
> Test #5: ruby-spec-test
> Test #16: c-object-tests
>
> The offending tests are like:
>
> Test #6: cpp_codec_test
> Test #25: go_example_electron_test
>
> I want to rename them as cpp-codec-test, go-example-electron-test etc.
>
> Only impact is if you use `ctest -R` to run tests selectively.
>
> Any objection? Silence is consent...
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
> For additional commands, e-mail: dev-help@qpid.apache.org
>
>
Re: ctest nit: rename cpp and go tests.
Posted by Alan Conway <ac...@redhat.com>.
On Fri, 2016-09-23 at 12:13 -0400, Chuck Rolke wrote:
> +1 The presumption is that you are referring to qpid-proton tests
> and�
> not qpid-cpp or qpid-dispatch or ...
>
> The widest ranging test is 'python-test'. This could be renamed to�
> 'proton-tests-of-all-sorts-using-python-test-framework'. When you�
> run python-test all the test logs print 'proton_tests.xx.yy'.�
> Is it python-test or proton_tests?�
>
python-test is the ctest target name, proton_tests is the python module
name. You're right it is a big grab bag.
Post my fix the test list is below. All tests start with <language>-,
except for java which is called "proton-java". All the auto-tested
examples are called <language>-example-<something>, after that it
depends on the language: cpp is cpp-<test_exe>, go just has one "go-
test" target that runs `go test` on the entire package set.
Some of the tests (go, python) can be run directly for finer control,
e.g.�
� � source config.sh && go test qpid.apache.org/electron -run SASL
Here's the list:
$ ctest -N
Test project /home/aconway/proton/reldbg_cl11
� Test��#1: proton-java
� Test��#2: python-test
� Test��#3: ruby-example-test
� Test��#4: ruby-unit-test
� Test��#5: ruby-spec-test
� Test��#6: cpp-codec_test
� Test��#7: cpp-engine_test
� Test��#8: cpp-thread_safe_test
� Test��#9: cpp-interop_test
� Test #10: cpp-message_test
� Test #11: cpp-scalar_test
� Test #12: cpp-value_test
� Test #13: cpp-container_test
� Test #14: cpp-url_test
� Test #15: go-test
� Test #16: c-object-tests
� Test #17: c-message-tests
� Test #18: c-engine-tests
� Test #19: c-parse-url-tests
� Test #20: c-refcount-tests
� Test #21: c-reactor-tests
� Test #22: c-event-tests
� Test #23: c-data-tests
� Test #24: c-condition-tests
� Test #25: go-example-electron
� Test #26: go-example-proton
� Test #27: cpp-example-mt
� Test #28: cpp-example-container
> The test scheme is what it is and there's only so much to gain by�
> cleaning it up. But if there is any gain at all then please do
> make improvements!
>
> -Chuck
>
> ----- Original Message -----
> >
> > From: "Alan Conway" <ac...@redhat.com>
> > To: "dev" <de...@qpid.apache.org>
> > Sent: Friday, September 23, 2016 11:33:23 AM
> > Subject: ctest nit: rename cpp and go tests.
> >
> > I'd like to rename the C++ and Go tests to use "-" instead of "_"
> > so
> > they are consistent with the other tests. This is my fault, I
> > wasn't
> > paying attention when I added the tests. The original tests are
> > like:
> >
> > � Test��#2: python-test
> > � Test��#5: ruby-spec-test
> > � Test #16: c-object-tests
> >
> > The offending tests are like:
> >
> > � Test��#6: cpp_codec_test
> > � Test #25: go_example_electron_test
> >
> > I want to rename them as cpp-codec-test, go-example-electron-test
> > etc.
> >
> > Only impact is if you use `ctest -R` to run tests selectively.
> >
> > Any objection? Silence is consent...
> >
> >
> > -----------------------------------------------------------------
> > ----
> > To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
> > For additional commands, e-mail: dev-help@qpid.apache.org
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
> For additional commands, e-mail: dev-help@qpid.apache.org
>
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org
Re: ctest nit: rename cpp and go tests.
Posted by Chuck Rolke <cr...@redhat.com>.
+1 The presumption is that you are referring to qpid-proton tests and
not qpid-cpp or qpid-dispatch or ...
The widest ranging test is 'python-test'. This could be renamed to
'proton-tests-of-all-sorts-using-python-test-framework'. When you
run python-test all the test logs print 'proton_tests.xx.yy'.
Is it python-test or proton_tests?
The test scheme is what it is and there's only so much to gain by
cleaning it up. But if there is any gain at all then please do
make improvements!
-Chuck
----- Original Message -----
> From: "Alan Conway" <ac...@redhat.com>
> To: "dev" <de...@qpid.apache.org>
> Sent: Friday, September 23, 2016 11:33:23 AM
> Subject: ctest nit: rename cpp and go tests.
>
> I'd like to rename the C++ and Go tests to use "-" instead of "_" so
> they are consistent with the other tests. This is my fault, I wasn't
> paying attention when I added the tests. The original tests are like:
>
> Test #2: python-test
> Test #5: ruby-spec-test
> Test #16: c-object-tests
>
> The offending tests are like:
>
> Test #6: cpp_codec_test
> Test #25: go_example_electron_test
>
> I want to rename them as cpp-codec-test, go-example-electron-test etc.
>
> Only impact is if you use `ctest -R` to run tests selectively.
>
> Any objection? Silence is consent...
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
> For additional commands, e-mail: dev-help@qpid.apache.org
>
>
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org