You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@kafka.apache.org by "KuiLIU (JIRA)" <ji...@apache.org> on 2018/04/19 16:14:00 UTC

[jira] [Created] (KAFKA-6807) Inconsistent method name

KuiLIU created KAFKA-6807:
-----------------------------

             Summary: Inconsistent method name
                 Key: KAFKA-6807
                 URL: https://issues.apache.org/jira/browse/KAFKA-6807
             Project: Kafka
          Issue Type: Improvement
            Reporter: KuiLIU


The following method is named as "readTo", but the method will return the variable with lesses value. Thus, the name "readTo" is inconsistent with the method body code.
Rename the method as "lesser" should be better.

{code:java}
    private Long readTo(final long endOffset) {
        return endOffset < offsetLimit ? endOffset : offsetLimit;
    }
{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)