You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@atlas.apache.org by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2025/02/10 06:31:00 UTC
[jira] [Commented] (ATLAS-4937) Code readability improvement
[ https://issues.apache.org/jira/browse/ATLAS-4937?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17925483#comment-17925483 ]
ASF subversion and git services commented on ATLAS-4937:
--------------------------------------------------------
Commit 1ec2dad4681aec6725e2a18ae71dd88c9d170da1 in atlas's branch refs/heads/master from Abhishek Kumar
[ https://gitbox.apache.org/repos/asf?p=atlas.git;h=1ec2dad46 ]
ATLAS-4937: checkstyle compliance updates - couchbase-bridge module (#282)
> Code readability improvement
> ----------------------------
>
> Key: ATLAS-4937
> URL: https://issues.apache.org/jira/browse/ATLAS-4937
> Project: Atlas
> Issue Type: Improvement
> Components: atlas-core, atlas-intg, atlas-webui
> Reporter: Madhan Neethiraj
> Assignee: Madhan Neethiraj
> Priority: Major
> Fix For: 3.0.0
>
> Attachments: ATLAS-4937.patch
>
> Time Spent: 50m
> Remaining Estimate: 0h
>
> Atlas code base has been evolving over many years, with contributions from large number of authors. Having a common coding style enforced during build time will help improve the readability of the code base. I propose to use [checkstyle|https://github.com/airlift/airbase/blob/master/airbase-policy/src/main/resources/checkstyle/airbase-checks.xml] based on airbase, which is used by open-source projects like Trino.
> Updating the entire code base will take considerable time, hence this will need to be done in phases, perhaps one module at a time. To start with, I suggest updating the checkstyle currently in the master branch but not fail the build in case of violations. This should be followed by updates to sources to comply with the checkstyle - one module at a time. Once all modules are updated, build should be updated to fail on violations.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)