You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@phoenix.apache.org by "Thomas D'Silva (JIRA)" <ji...@apache.org> on 2018/08/04 19:08:00 UTC

[jira] [Commented] (PHOENIX-4647) Column header doesn't handle optional arguments correctly

    [ https://issues.apache.org/jira/browse/PHOENIX-4647?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16569268#comment-16569268 ] 

Thomas D'Silva commented on PHOENIX-4647:
-----------------------------------------

nit:

Instead of using the for loop, since SUBSTR has only three child expressions the code would be easier to read if you referred to the expressions using the methods getStrExpression(), getOffsetExpression() and getLengthExpression()

> Column header doesn't handle optional arguments correctly
> ---------------------------------------------------------
>
>                 Key: PHOENIX-4647
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-4647
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 4.14.0
>            Reporter: Shehzaad Nakhoda
>            Assignee: Xu Cang
>            Priority: Major
>         Attachments: PHOENIX-4647.master.001.patch
>
>
> SUBSTR(NAME, 1)
> being rendered as 
> SUBSTR(NAME, 1, )
> in things like column headings.
> For example:
> 0: jdbc:phoenix:> create table hello_table (ID DECIMAL PRIMARY KEY, NAME VARCHAR);
> No rows affected (1.252 seconds)
> 0: jdbc:phoenix:> upsert into hello_table values(1, 'abc');
> 1 row affected (0.025 seconds)
> 0: jdbc:phoenix:> select substr(name, 1) from hello_table;
> +--------------------+
> | SUBSTR(NAME, 1, )  |
> +--------------------+
> | abc                |
> +--------------------+
> Looks to me like there's a bug - 
> SUBSTR(NAME, 1) should be represented as SUBSTR(NAME, 1) not as SUBSTR(NAME, 1, )



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)