You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@tez.apache.org by "Bikas Saha (JIRA)" <ji...@apache.org> on 2015/07/28 19:35:05 UTC

[jira] [Commented] (TEZ-2645) Provide standard analyzers for job analysis

    [ https://issues.apache.org/jira/browse/TEZ-2645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14644715#comment-14644715 ] 

Bikas Saha commented on TEZ-2645:
---------------------------------

+1
The overall organization looks good. My guess is that the heuristics will improve with more use cases.

Why is io.dropwizard.metrics added to the pom?

Rename tez-tools/perf-analyzer to just tez-tools/analyzers?

Should these constants for counter names be defined in tez-runtime-library (in case they already are not)? HDFS_BYTE_READ etc.

> Provide standard analyzers for job analysis
> -------------------------------------------
>
>                 Key: TEZ-2645
>                 URL: https://issues.apache.org/jira/browse/TEZ-2645
>             Project: Apache Tez
>          Issue Type: Improvement
>            Reporter: Rajesh Balamohan
>            Assignee: Rajesh Balamohan
>         Attachments: TEZ-2645.1.patch
>
>
> TEZ-2076 provided a way in which job history data can be parsed/normalized and represented in-memory. Based on this, standard set of analyzers (e.g ContainerReuseAnalyzer, LocalityAnalyzer, SlowNodeAnalyzer etc) can provided in tez-tools for job analysis. Results can be stored in CSVResult which could be rendered differently based on UI requirements.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)