You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Gilles (Commented) (JIRA)" <ji...@apache.org> on 2012/02/02 12:01:57 UTC

[jira] [Commented] (MATH-736) Multidimensional FFT

    [ https://issues.apache.org/jira/browse/MATH-736?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13198686#comment-13198686 ] 

Gilles commented on MATH-736:
-----------------------------

You could already mark those methods (and class) as "@deprecated".

                
> Multidimensional FFT
> --------------------
>
>                 Key: MATH-736
>                 URL: https://issues.apache.org/jira/browse/MATH-736
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Sébastien Brisard
>            Priority: Minor
>              Labels: transform
>             Fix For: 3.1, 4.0
>
>
> This is a continuation of MATH-677. In {{o.a.c.m.transform.FastFourierTransformer}}
> * methods {{mdfft}} and {{verifyDataSet}} take an argument of type {{Object}} (to allow an argument with an unspecified number of dimensions)
> * for clarity, multidimensional transform should be moved to a class of its own (and I also wonder whether the {{MultiDimensionalComplexMatrix}} name is not misleading)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira