You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Philip Martin <ph...@codematters.co.uk> on 2004/05/23 17:36:53 UTC

Re: svn commit: r9814 - trunk/subversion/libsvn_wc

breser@tigris.org writes:

> Author: breser
> Date: Fri May 21 01:44:19 2004
> New Revision: 9814
>
> --- trunk/subversion/libsvn_wc/props.c	(original)
> +++ trunk/subversion/libsvn_wc/props.c	Fri May 21 01:44:19 2004
> @@ -347,7 +347,7 @@
>  
>    const char *access_path = svn_wc_adm_access_path (adm_access);
>    int access_len = strlen (access_path);
> -  int slash = access_len ? 1 : 0;   /* "foo/.svn/..." versus ".svn/..." */
> +  int slash = 1;

This intialisation...

>    const char *entryname;
>    const char *full_path;
> @@ -363,6 +363,10 @@
>  
>    apr_file_t *reject_tmp_fp = NULL;       /* the temporary conflicts file */
>    const char *reject_tmp_path = NULL;
> +
> +  /* Empty path and paths ending in / don't need an extra slash removed */
> +  if (access_len == 0 || access_path[access_len - 1] == '/')
> +    slash = 0;

...and this bit of code would be (very marginally) more readable if
they were not split up.



-- 
Philip Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: r9814 - trunk/subversion/libsvn_wc

Posted by Ben Reser <be...@reser.org>.
On Sun, May 23, 2004 at 06:36:53PM +0100, Philip Martin wrote:
> breser@tigris.org writes:
> 
> > Author: breser
> > Date: Fri May 21 01:44:19 2004
> > New Revision: 9814
> >
> > --- trunk/subversion/libsvn_wc/props.c	(original)
> > +++ trunk/subversion/libsvn_wc/props.c	Fri May 21 01:44:19 2004
> > @@ -347,7 +347,7 @@
> >  
> >    const char *access_path = svn_wc_adm_access_path (adm_access);
> >    int access_len = strlen (access_path);
> > -  int slash = access_len ? 1 : 0;   /* "foo/.svn/..." versus ".svn/..." */
> > +  int slash = 1;
> 
> This intialisation...
> 
> >    const char *entryname;
> >    const char *full_path;
> > @@ -363,6 +363,10 @@
> >  
> >    apr_file_t *reject_tmp_fp = NULL;       /* the temporary conflicts file */
> >    const char *reject_tmp_path = NULL;
> > +
> > +  /* Empty path and paths ending in / don't need an extra slash removed */
> > +  if (access_len == 0 || access_path[access_len - 1] == '/')
> > +    slash = 0;
> 
> ...and this bit of code would be (very marginally) more readable if
> they were not split up.

Done in r10118

-- 
Ben Reser <be...@reser.org>
http://ben.reser.org

"Conscience is the inner voice which warns us somebody may be looking."
- H.L. Mencken

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org