You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jackrabbit.apache.org by "angela (JIRA)" <ji...@apache.org> on 2008/04/25 17:14:00 UTC

[jira] Resolved: (JCR-1550) Remove ItemInfo.getName() since it is redundant

     [ https://issues.apache.org/jira/browse/JCR-1550?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

angela resolved JCR-1550.
-------------------------

    Resolution: Fixed
      Assignee: angela

no objections. assuming lazy consensus.

trunk: completed at revision 651626  


> Remove ItemInfo.getName() since it is redundant
> -----------------------------------------------
>
>                 Key: JCR-1550
>                 URL: https://issues.apache.org/jira/browse/JCR-1550
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: jackrabbit-spi
>    Affects Versions: 1.4
>            Reporter: Michael Dürig
>            Assignee: angela
>            Priority: Minor
>         Attachments: JCR-1550.diff
>
>
> I propose to remove the method getName() from org.apache.jackrabbit.spi.ItemInfo since it is redundant. The name is always the last element of the path which is available via the getPath() method.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.