You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Elliott Clark (JIRA)" <ji...@apache.org> on 2015/08/11 19:57:46 UTC
[jira] [Comment Edited] (HBASE-14203) remove duplicate code
getTableDescriptor in HTable
[ https://issues.apache.org/jira/browse/HBASE-14203?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14682169#comment-14682169 ]
Elliott Clark edited comment on HBASE-14203 at 8/11/15 5:57 PM:
----------------------------------------------------------------
Don't synchronize on a non-final field. Additionally I'm pretty sure that most of the tests are failing as they assume that getAdmin will create a new HBaseAdmin.
was (Author: eclark):
Don't synchronize on a non-final field.
> remove duplicate code getTableDescriptor in HTable
> --------------------------------------------------
>
> Key: HBASE-14203
> URL: https://issues.apache.org/jira/browse/HBASE-14203
> Project: HBase
> Issue Type: Improvement
> Reporter: Heng Chen
> Priority: Trivial
> Attachments: HBASE-14203.patch, HBASE-14203_v2.patch
>
>
> As TODO in comment said,
> {{HTable.getTableDescriptor}} is same as {{HAdmin.getTableDescriptor}}. remove the duplicate code.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)