You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Daishuyuan (Jira)" <ji...@apache.org> on 2026/03/26 02:53:00 UTC
[jira] [Created] (FLINK-39327) Rename gaussdws pipeline sink connector to dws
Daishuyuan created FLINK-39327:
----------------------------------
Summary: Rename gaussdws pipeline sink connector to dws
Key: FLINK-39327
URL: https://issues.apache.org/jira/browse/FLINK-39327
Project: Flink
Issue Type: Improvement
Components: Flink CDC
Reporter: Daishuyuan
The existing pipeline sink connector is currently exposed as {code}gaussdws{code} in the module name, package name, service registration, and factory identifier.
However, the underlying dependency and connector runtime already use DWS:
* Maven dependency: {code}com.huaweicloud.dws:dws-connector-flink{code}
* connector classes already use the {code}Dws*{code} naming
This naming is inconsistent and can be confusing for users, especially in pipeline YAML where the sink type is currently {code}gaussdws{code}.
This issue proposes to rename the connector consistently from {code}gaussdws{code} to {code}dws{code}.
Scope:
* rename module {code}flink-cdc-pipeline-connector-gaussdws{code} to {code}flink-cdc-pipeline-connector-dws{code}
* rename Java packages and classes from {code}org.apache.flink.cdc.connectors.gaussdws.*{code} to {code}org.apache.flink.cdc.connectors.dws.*{code}
* rename the factory identifier from {code}gaussdws{code} to {code}dws{code}
* update service loader registration
* update related tests and pipeline YAML examples
The change is mainly a naming cleanup and should not introduce new sink behavior.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)