You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Jinglun (JIRA)" <ji...@apache.org> on 2019/08/01 02:37:00 UTC
[jira] [Commented] (HDFS-13901) INode access time is ignored
because of race between open and rename
[ https://issues.apache.org/jira/browse/HDFS-13901?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16897708#comment-16897708 ]
Jinglun commented on HDFS-13901:
--------------------------------
Upload patch-002 making the unit test more readable. Do you have time to review this [~jojochuang], thanks a lot. :)
> INode access time is ignored because of race between open and rename
> --------------------------------------------------------------------
>
> Key: HDFS-13901
> URL: https://issues.apache.org/jira/browse/HDFS-13901
> Project: Hadoop HDFS
> Issue Type: Bug
> Reporter: Jinglun
> Assignee: Jinglun
> Priority: Major
> Attachments: HDFS-13901.000.patch, HDFS-13901.001.patch, HDFS-13901.002.patch
>
>
> That's because in getBlockLocations there is a gap between readUnlock and re-fetch write lock (to update access time). If a rename operation occurs in the gap, the update of access time will be ignored. We can calculate new path from the inode and use the new path to update access time.
--
This message was sent by Atlassian JIRA
(v7.6.14#76016)
---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org