You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@trafficserver.apache.org by Damian Meden <da...@yahooinc.com.INVALID> on 2023/12/18 10:40:01 UTC

Re: [E] [PROPOSAL] Remove "proxy.process" prefix from all core metrics

+1 to remove the `proxy.process`

I don't like either #1 or #2 although I agree to have a single prefix. I
think eventually we will have this same conversation about `proxy.config`
so to me a name that means the scope of the record should be used, `ats`
seems too generic as can also be used by a config record(unless this is
what we want).

Maybe just `metric` or `stat` could work.

Thanks.
Damian.

On Mon, Dec 18, 2023 at 3:29 AM Leif Hedstrom <zw...@apache.org> wrote:

> Through all our cleanup and refactoring in the past, as far as I can tell,
> all metrics are now prefixed with proxy.process.
>
> This seems a little superfluous. I’d like to suggests one of two options:
>
> 1. Just drop the prefix entirely.
>
> 2. Replace the prefix with “ats”.
>
>
> Thoughts?
>
> — Leif
>
>

Re: [E] [PROPOSAL] Remove "proxy.process" prefix from all core metrics

Posted by Damian Meden <da...@yahooinc.com.INVALID>.
>To distinguish from “config” ? I mean, it’s obviously a metric or stat at
this point already :).

What I meant by this is, how do we know that `ats` means only `metric`? and
not a config record. Anyway, I am +1 to drop the `proxy.process` . I am
just inclined  to have a prefix which can be used to scope what's on the
right side of the prefix.

Damian.

On Mon, Dec 18, 2023 at 6:17 PM Leif Hedstrom <zw...@apache.org> wrote:

>
>
> > On Dec 18, 2023, at 3:40 AM, Damian Meden <da...@yahooinc.com.INVALID>
> wrote:
> >
> > +1 to remove the `proxy.process`
> >
> > I don't like either #1 or #2 although I agree to have a single prefix. I
> > think eventually we will have this same conversation about `proxy.config`
> > so to me a name that means the scope of the record should be used, `ats`
> > seems too generic as can also be used by a config record(unless this is
> > what we want).
> >
> > Maybe just `metric` or `stat` could work.
>
>
> To distinguish from “config” ? I mean, it’s obviously a metric or stat at
> this point already :).
>
>
> — Leif
>
> >
> > Thanks.
> > Damian.
> >
> > On Mon, Dec 18, 2023 at 3:29 AM Leif Hedstrom <zw...@apache.org> wrote:
> >
> >> Through all our cleanup and refactoring in the past, as far as I can
> tell,
> >> all metrics are now prefixed with proxy.process.
> >>
> >> This seems a little superfluous. I’d like to suggests one of two
> options:
> >>
> >> 1. Just drop the prefix entirely.
> >>
> >> 2. Replace the prefix with “ats”.
> >>
> >>
> >> Thoughts?
> >>
> >> — Leif
> >>
> >>
>
>

Re: [E] [PROPOSAL] Remove "proxy.process" prefix from all core metrics

Posted by Leif Hedstrom <zw...@apache.org>.

> On Dec 18, 2023, at 3:40 AM, Damian Meden <da...@yahooinc.com.INVALID> wrote:
> 
> +1 to remove the `proxy.process`
> 
> I don't like either #1 or #2 although I agree to have a single prefix. I
> think eventually we will have this same conversation about `proxy.config`
> so to me a name that means the scope of the record should be used, `ats`
> seems too generic as can also be used by a config record(unless this is
> what we want).
> 
> Maybe just `metric` or `stat` could work.


To distinguish from “config” ? I mean, it’s obviously a metric or stat at this point already :).


— Leif

> 
> Thanks.
> Damian.
> 
> On Mon, Dec 18, 2023 at 3:29 AM Leif Hedstrom <zw...@apache.org> wrote:
> 
>> Through all our cleanup and refactoring in the past, as far as I can tell,
>> all metrics are now prefixed with proxy.process.
>> 
>> This seems a little superfluous. I’d like to suggests one of two options:
>> 
>> 1. Just drop the prefix entirely.
>> 
>> 2. Replace the prefix with “ats”.
>> 
>> 
>> Thoughts?
>> 
>> — Leif
>> 
>> 


Re: [E] [PROPOSAL] Remove "proxy.process" prefix from all core metrics

Posted by Leif Hedstrom <zw...@apache.org>.

> On Dec 18, 2023, at 3:40 AM, Damian Meden <da...@yahooinc.com.INVALID> wrote:
> 
> +1 to remove the `proxy.process`
> 
> I don't like either #1 or #2 although I agree to have a single prefix. I
> think eventually we will have this same conversation about `proxy.config`
> so to me a name that means the scope of the record should be used, `ats`
> seems too generic as can also be used by a config record(unless this is
> what we want).
> 
> Maybe just `metric` or `stat` could work.


To distinguish from “config” ? I mean, it’s obviously a metric or stat at this point already :).


— Leif

> 
> Thanks.
> Damian.
> 
> On Mon, Dec 18, 2023 at 3:29 AM Leif Hedstrom <zw...@apache.org> wrote:
> 
>> Through all our cleanup and refactoring in the past, as far as I can tell,
>> all metrics are now prefixed with proxy.process.
>> 
>> This seems a little superfluous. I’d like to suggests one of two options:
>> 
>> 1. Just drop the prefix entirely.
>> 
>> 2. Replace the prefix with “ats”.
>> 
>> 
>> Thoughts?
>> 
>> — Leif
>> 
>>