You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@geode.apache.org by Anthony Baker <ab...@apache.org> on 2018/02/22 21:46:43 UTC
[SECURITY] CVE-2017-15696 Apache Geode configuration request
authorization vulnerability
CVE-2017-15696 Apache Geode configuration request authorization vulnerability
Severity: Important
Vendor: The Apache Software Foundation
Versions Affected: Apache Geode 1.0.0 through 1.3.0
Description:
The Geode configuration service does not properly authorize
configuration requests. This allows an unprivileged user who gains
access to the Geode locator to extract configuration data and
previously deployed application code.
Mitigation:
Users of the affected versions should upgrade to Apache Geode 1.4.0 or later.
Credit:
This issue was reported responsibly to the Apache Geode Security Team
by Dan Smith from Pivotal.
References:
[1] https://issues.apache.org/jira/browse/GEODE-3962
[2] https://cwiki.apache.org/confluence/display/GEODE/Release+Notes#ReleaseNotes-SecurityVulnerabilities