You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Jian He (JIRA)" <ji...@apache.org> on 2013/05/18 00:59:16 UTC
[jira] [Moved] (HDFS-4838) Move addPersistedDelegationToken to
AbstractDelegationTokenSecretManager
[ https://issues.apache.org/jira/browse/HDFS-4838?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Jian He moved YARN-697 to HDFS-4838:
------------------------------------
Issue Type: Improvement (was: Bug)
Key: HDFS-4838 (was: YARN-697)
Project: Hadoop HDFS (was: Hadoop YARN)
> Move addPersistedDelegationToken to AbstractDelegationTokenSecretManager
> ------------------------------------------------------------------------
>
> Key: HDFS-4838
> URL: https://issues.apache.org/jira/browse/HDFS-4838
> Project: Hadoop HDFS
> Issue Type: Improvement
> Reporter: Jian He
>
> Is it possible to move addPersistedDelegationToken in DelegationTokenSecretManager to AbstractDelegationTokenSecretManager?
> Also, Is it possible to rename logUpdateMasterKey to storeNewMasterKey AND logExpireToken to removeStoredToken for persisting and recovering keys/tokens?
> These methods are likely to be common methods and be used by overridden secretManager
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira