You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2026/06/25 08:38:31 UTC
(httpcomponents-website) branch master updated: Updated website for HttpCore 5.4.3 and HttpCore 5.5-beta2 releases
This is an automated email from the ASF dual-hosted git repository.
ok2c pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-website.git
The following commit(s) were added to refs/heads/master by this push:
new 1b72dda Updated website for HttpCore 5.4.3 and HttpCore 5.5-beta2 releases
1b72dda is described below
commit 1b72dda124ce8cf01c6ca2fe9bd9a3af64acfa12
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Thu Jun 25 10:32:23 2026 +0200
Updated website for HttpCore 5.4.3 and HttpCore 5.5-beta2 releases
---
src/site/markdown/download.md | 52 +++++++++++-----------
src/site/markdown/news.md | 42 ++++++++---------
.../httpcomponents-core-5.4.x/documentation.links | 3 +-
.../httpcomponents-core-5.5.x/documentation.links | 3 +-
src/site/site.xml | 2 +-
5 files changed, 52 insertions(+), 50 deletions(-)
diff --git a/src/site/markdown/download.md b/src/site/markdown/download.md
index 3b1d6e1..3fcb93a 100644
--- a/src/site/markdown/download.md
+++ b/src/site/markdown/download.md
@@ -53,53 +53,53 @@ Source
[[sha512](https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.6.1-src.zip.sha512)]
[[pgp](https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.6.1-src.zip.asc)]
-HttpCore 5.4.2 (GA)
+HttpCore 5.4.3 (GA)
------------------
[KEYS](https://downloads.apache.org/httpcomponents/httpcore/KEYS) |
[Release Notes](https://downloads.apache.org/httpcomponents/httpcore/RELEASE_NOTES-5.4.x.txt)
Binaries
-* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.4.2-bin.tar.gz)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.2-bin.tar.gz.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.2-bin.tar.gz.asc)]
-* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.4.2-bin.zip)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.2-bin.zip.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.2-bin.zip.asc)]
+* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.4.3-bin.tar.gz)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.3-bin.tar.gz.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.3-bin.tar.gz.asc)]
+* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.4.3-bin.zip)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.3-bin.zip.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.4.3-bin.zip.asc)]
Source
-* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.4.2-src.tar.gz)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.2-src.tar.gz.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.2-src.tar.gz.asc)]
+* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.4.3-src.tar.gz)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.3-src.tar.gz.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.3-src.tar.gz.asc)]
-* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.4.2-src.zip)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.2-src.zip.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.2-src.zip.asc)]
+* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.4.3-src.zip)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.3-src.zip.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.4.3-src.zip.asc)]
-HttpCore 5.5-beta1
+HttpCore 5.5-beta2
------------------
[KEYS](https://downloads.apache.org/httpcomponents/httpcore/KEYS) |
[Release Notes](https://downloads.apache.org/httpcomponents/httpcore/RELEASE_NOTES-5.5.x.txt)
Binaries
-* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta1-bin.tar.gz)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta1-bin.tar.gz.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta1-bin.tar.gz.asc)]
-* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta1-bin.zip)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta1-bin.zip.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta1-bin.zip.asc)]
+* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta2-bin.tar.gz)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta2-bin.tar.gz.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta2-bin.tar.gz.asc)]
+* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta2-bin.zip)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta2-bin.zip.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.5-beta2-bin.zip.asc)]
Source
-* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta1-src.tar.gz)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta1-src.tar.gz.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta1-src.tar.gz.asc)]
+* [tar.gz](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta2-src.tar.gz)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta2-src.tar.gz.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta2-src.tar.gz.asc)]
-* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta1-src.zip)
- [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta1-src.zip.sha512)]
- [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta1-src.zip.asc)]
+* [zip](http://www.apache.org/dyn/closer.lua/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta2-src.zip)
+ [[sha512](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta2-src.zip.sha512)]
+ [[pgp](https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.5-beta2-src.zip.asc)]
Older releases
----------------
diff --git a/src/site/markdown/news.md b/src/site/markdown/news.md
index f6070b5..7b22dea 100644
--- a/src/site/markdown/news.md
+++ b/src/site/markdown/news.md
@@ -20,12 +20,11 @@
HttpComponents Project News
===========================
-###### 5 June 2026 - HttpComponents Core 5.5-beta1 released
+###### 25 June 2026 - HttpComponents Core 5.5-beta2 released
-This is the first BETA release in the 5.5 release series that improves performance and
-robustness of connection pool implementations, further improves HTTP/2 specification
-conformance and introduces JSON message content bindings based on
-[Jackson](https://github.com/fasterxml/jackson) version 2.
+This BETA release corrects Java 8 binary problem introduced in the previous BETA
+release. The previous version has been compiled against Java 17 APIs by mistake.
+This release also adds support for QUERY method (RFC 10008).
Notable changes and features included in the 5.5 series:
@@ -37,10 +36,25 @@ Notable changes and features included in the 5.5 series:
* Cap pending HTTP/2 request commands per connection.
-* HPACK RFC 7540 / RFC 7541 / HTTP/2 RFC 9113 conformance improvements.
+* HPACK RFC 7540, RFC 7541, and HTTP/2 RFC 9113 conformance improvements.
+
+* Building HttpCore with Maven now requires Java 17 or newer. Published
+ artifacts remain compatible with Java 8.
+
+* QUERY method support (RFC 10008).
-* JSON message content bindings
+###### 25 June 2026 - HttpComponents Core 5.4.3 released
+This maintenance release fixes several defects and regression reported since the previous
+release including a regression in backpressure handling of async TLS sessions introduced
+in version 5.3.3.
+
+###### 5 June 2026 - HttpComponents Core 5.5-beta1 released
+
+This is the first BETA release in the 5.5 release series that improves performance and
+robustness of connection pool implementations, further improves HTTP/2 specification
+conformance and introduces JSON message content bindings based on
+[Jackson](https://github.com/fasterxml/jackson) version 2.
###### 20 April 2026 - HttpComponents Client 5.6.1 GA released
@@ -56,20 +70,6 @@ robustness of connection pool implementations, further improves HTTP/2 specifica
conformance and introduces JSON message content bindings based on
[Jackson](https://github.com/fasterxml/jackson) version 2.
-Notable changes and features included in the 5.5 series:
-
-* Connection pool implementation improvements.
-
-* HTTP message stream APIs and support for HTTP/2 message stream timeout.
-
-* SSLContexts to respect system properties by default.
-
-* Cap pending HTTP/2 request commands per connection.
-
-* HPACK RFC 7540 / RFC 7541 / HTTP/2 RFC 9113 conformance improvements.
-
-* JSON message content bindings
-
###### 6 March 2026 - HttpComponents Core 5.4.2 GA released
This maintenance release fixes a bug in the lax connection pool where expired connection
diff --git a/src/site/resources/httpcomponents-core-5.4.x/documentation.links b/src/site/resources/httpcomponents-core-5.4.x/documentation.links
index 228cd89..b6c67ca 100644
--- a/src/site/resources/httpcomponents-core-5.4.x/documentation.links
+++ b/src/site/resources/httpcomponents-core-5.4.x/documentation.links
@@ -23,4 +23,5 @@
5.4 ../components/httpcomponents-core-5.4.x/5.4
5.4.1 ../components/httpcomponents-core-5.4.x/5.4.1
5.4.2 ../components/httpcomponents-core-5.4.x/5.4.2
-current ../components/httpcomponents-core-5.4.x/5.4.2
+5.4.3 ../components/httpcomponents-core-5.4.x/5.4.3
+current ../components/httpcomponents-core-5.4.x/5.4.3
diff --git a/src/site/resources/httpcomponents-core-5.5.x/documentation.links b/src/site/resources/httpcomponents-core-5.5.x/documentation.links
index 5a7c4a0..2e25af9 100644
--- a/src/site/resources/httpcomponents-core-5.5.x/documentation.links
+++ b/src/site/resources/httpcomponents-core-5.5.x/documentation.links
@@ -22,4 +22,5 @@
5.5-alpha1 ../components/httpcomponents-core-5.5.x/5.5-alpha1
5.5-beta1 ../components/httpcomponents-core-5.5.x/5.5-beta1
-current ../components/httpcomponents-core-5.5.x/5.5-beta1
+5.5-beta2 ../components/httpcomponents-core-5.5.x/5.5-beta2
+current ../components/httpcomponents-core-5.5.x/5.5-beta2
diff --git a/src/site/site.xml b/src/site/site.xml
index d1d92e5..5e3f504 100644
--- a/src/site/site.xml
+++ b/src/site/site.xml
@@ -95,7 +95,7 @@ under the License.
<item name="Examples" href="httpcomponents-core-5.4.x/examples.html"/>
<item name="Download" href="httpcomponents-core-5.4.x/download.html"/>
</item>
- <item name="HttpCore 5.5 ALPHA" collapse="true" href="httpcomponents-core-5.5.x/index.html">
+ <item name="HttpCore 5.5 BETA" collapse="true" href="httpcomponents-core-5.5.x/index.html">
<item name="JSON bindings" href="httpcomponents-core-5.5.x/json-jackson2.html"/>
<item name="Examples (Classic)" href="httpcomponents-core-5.5.x/examples.html"/>
<item name="Examples (Async)" href="httpcomponents-core-5.5.x/examples-async.html"/>