You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@beam.apache.org by "Heejong Lee (JIRA)" <ji...@apache.org> on 2019/05/03 23:14:00 UTC
[jira] [Commented] (BEAM-7143) adding withConsumerConfigUpdates
[ https://issues.apache.org/jira/browse/BEAM-7143?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16832913#comment-16832913 ]
Heejong Lee commented on BEAM-7143:
-----------------------------------
I still think that giving `with` prefix is better than using `update` prefix. From my own experience, IĀ could find `withOffsetConsumerConfigOverrides` option pretty quickly but it took some time to figure out there's another option `updateConsumerProperties`. As far as I can see, `updateConsumerProperties` and `updateProducerProperties` are two only configuration methods which use `update` prefix. Is there any specific reason that only those two methods use `update` prefix?
> adding withConsumerConfigUpdates
> --------------------------------
>
> Key: BEAM-7143
> URL: https://issues.apache.org/jira/browse/BEAM-7143
> Project: Beam
> Issue Type: Improvement
> Components: io-java-kafka
> Reporter: Heejong Lee
> Assignee: Heejong Lee
> Priority: Minor
> Time Spent: 20m
> Remaining Estimate: 0h
>
> To modify `ConsumerConfig` for main consumer, we use `updateConsumerProperties`. However, to modify `ConsumerConfig` for offset consumer, the right method is `withOffsetConsumerConfigOverrides`. It would be good to match both names for improving usability.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)