You are viewing a plain text version of this content. The canonical link for it is here.
Posted to oak-issues@jackrabbit.apache.org by "Michael Dürig (JIRA)" <ji...@apache.org> on 2016/09/05 12:38:20 UTC
[jira] [Commented] (OAK-4746) Move writeFile into the TarWriter
[ https://issues.apache.org/jira/browse/OAK-4746?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15464912#comment-15464912 ]
Michael Dürig commented on OAK-4746:
------------------------------------
+1
The only thing I'm not too sure about is {{TarWriter.renew()}} incrementing the writer index. Isn't the writer index a concern of the store, not of the {{TarWriter}}? Shouldn't we better pass the writer index as an argument to that method? Alternatively we could rename that method to {{createNextGeneration()}} and add clarifying Jacadocs regarding what it does to the numbering.
> Move writeFile into the TarWriter
> ---------------------------------
>
> Key: OAK-4746
> URL: https://issues.apache.org/jira/browse/OAK-4746
> Project: Jackrabbit Oak
> Issue Type: Improvement
> Components: segment-tar
> Reporter: Alex Parvulescu
> Assignee: Alex Parvulescu
> Priority: Minor
> Fix For: Segment Tar 0.0.12
>
> Attachments: OAK-4746.patch
>
>
> Minor refactoring item. I'd like to move the {{writeFile}} instance from the {{FileStore}} into the {{TarWriter}}.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)