You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Uma Maheswara Rao G (JIRA)" <ji...@apache.org> on 2013/04/25 15:50:20 UTC

[jira] [Commented] (HADOOP-8240) Allow users to specify a checksum type on create()

    [ https://issues.apache.org/jira/browse/HADOOP-8240?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13641799#comment-13641799 ] 

Uma Maheswara Rao G commented on HADOOP-8240:
---------------------------------------------

This fix works for me.
{code}
--- hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java	(revision 16191)
+++ hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java	(working copy)
@@ -169,6 +169,9 @@
   }
 
   static byte[] int2byte(int integer, byte[] bytes) {
+    if (bytes.length == 0) {
+      return bytes;
+    }
     bytes[0] = (byte)((integer >>> 24) & 0xFF);
     bytes[1] = (byte)((integer >>> 16) & 0xFF);
     bytes[2] = (byte)((integer >>>  8) & 0xFF);

{code}
What do you say Kihwal? do you agree with this small change or you have other fix in your mind?
                
> Allow users to specify a checksum type on create()
> --------------------------------------------------
>
>                 Key: HADOOP-8240
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8240
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.23.0
>            Reporter: Kihwal Lee
>            Assignee: Kihwal Lee
>             Fix For: 0.23.3, 2.0.2-alpha
>
>         Attachments: hadoop-8240-branch-0.23-alone.patch.txt, hadoop-8240.patch, hadoop-8240-post-hadoop-8700-br2-trunk.patch.txt, hadoop-8240-post-hadoop-8700-br2-trunk.patch.txt, hadoop-8240-trunk-branch2.patch.txt, hadoop-8240-trunk-branch2.patch.txt, hadoop-8240-trunk-branch2.patch.txt
>
>
> Per discussion in HADOOP-8060, a way for users to specify a checksum type on create() is needed. The way FileSystem cache works makes it impossible to use dfs.checksum.type to achieve this. Also checksum-related API is at Filesystem-level, so we prefer something at that level, not hdfs-specific one.  Current proposal is to use CreatFlag.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira