You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@olingo.apache.org by "Sharath Babu (Jira)" <ji...@apache.org> on 2022/10/28 18:19:00 UTC

[jira] [Created] (OLINGO-1590) Hardcoding "geo" prefix to dictate deserialization policy is an ugly hack

Sharath Babu created OLINGO-1590:
------------------------------------

             Summary: Hardcoding "geo" prefix to dictate deserialization policy is an ugly hack
                 Key: OLINGO-1590
                 URL: https://issues.apache.org/jira/browse/OLINGO-1590
             Project: Olingo
          Issue Type: Bug
          Components: odata4-server
    Affects Versions: (Java) V4 4.9.0
            Reporter: Sharath Babu


In OdataJsonDeserializer, there is logic that looks at the name of an enum type, and if the name starts with "Geo", apply different deserialization logic to the type: 

[https://github.com/apache/olingo-odata4/blob/64b1a449de6271ff1b74f4927599ccfda553e0fc/lib/server-core/src/main/java/org/apache/olingo/server/core/deserializer/json/ODataJsonDeserializer.java#L824]

This is not a sane/nice way to hardcode behavior. If this enum type needs special handling, it should have an attribute on the type definition to indicate how to deserialize it, not hardcoded assumptions based on type name. 



--
This message was sent by Atlassian Jira
(v8.20.10#820010)