You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Brian de Alwis (JIRA)" <ji...@codehaus.org> on 2014/04/04 17:50:00 UTC

[jira] (MPLUGIN-263) Generated plugin-help.xml uses field name rather than parameter property name

Brian de Alwis created MPLUGIN-263:
--------------------------------------

             Summary: Generated plugin-help.xml uses field name rather than parameter property name
                 Key: MPLUGIN-263
                 URL: https://jira.codehaus.org/browse/MPLUGIN-263
             Project: Maven Plugin Tools
          Issue Type: Bug
          Components: Plugin Plugin
    Affects Versions: 3.2
            Reporter: Brian de Alwis
            Priority: Minor
         Attachments: plugin-help.xml

The org.eclipse.ebr:ebr-maven-plugin [1] uses Java5 annotations to indicate plugin parameters.  It has one parameter [2] where the parameter property name does not match the field name.

        @Parameter(property = "version", defaultValue = "RELEASE")
        private String artifactVersion;

The resulting plugin-help.xml document (attached) references the field name, and not the property name.

        <parameter>
          <name>artifactVersion</name>
          <type>java.lang.String</type>
          <required>false</required>
          <editable>true</editable>
          <description></description>
        </parameter>

This should use the parameter property name, "version".

[1] Download a snapshot at <https://git.eclipse.org/c/ebr/org.eclipse.ebr.recipes.git/snapshot/org.eclipse.ebr.recipes-master.zip> and look in releng/ebr-maven-plugin

[2] Code for this mojo: <https://git.eclipse.org/c/ebr/org.eclipse.ebr.recipes.git/tree/releng/ebr-maven-plugin/src/main/java/org/eclipse/ebr/maven/CreateRecipeMojo.java>



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)