You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Valentin Kulichenko (Jira)" <ji...@apache.org> on 2021/09/21 10:05:00 UTC
[jira] [Created] (IGNITE-15548) [Ignite 3] Fix Table API hierarchy
Valentin Kulichenko created IGNITE-15548:
--------------------------------------------
Summary: [Ignite 3] Fix Table API hierarchy
Key: IGNITE-15548
URL: https://issues.apache.org/jira/browse/IGNITE-15548
Project: Ignite
Issue Type: Task
Affects Versions: 3.0.0-alpha2
Reporter: Valentin Kulichenko
Fix For: 3.0.0-alpha3
Current version of the Table API is a little confusing and inconsistent. Need to make the following changes:
# Remove {{RecordView}} and {{KeyValueBinaryView}} interfaces.
# Rename {{TableView}} to {{RecordView}}.
# Remove {{extends TableView<Tuple>}} from the {{Table}} interface.
# Change the return type of {{Table#kvView()}} to {{KeyValueView<Tuple>}}.
# Add new method to the {{Table}} interface: {{RecordView<Tuple> recordView();}}
--
This message was sent by Atlassian Jira
(v8.3.4#803005)