You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@spark.apache.org by "Sean Owen (JIRA)" <ji...@apache.org> on 2015/04/21 12:49:59 UTC
[jira] [Commented] (SPARK-7028) Add filterNot to RDD
[ https://issues.apache.org/jira/browse/SPARK-7028?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14504757#comment-14504757 ]
Sean Owen commented on SPARK-7028:
----------------------------------
That seems reasonable; at the same time of course you can {{filterNot(x => f(x))}} with {{filter(x => !f(x))}} so this doesn't buy much. I understand it's so that you can write {{filterNot(f)}} rather than expand to the preceding form. That's a minor case and I suppose I'm neutral to slightly negative on whether it's even worth the small cost of another API method and tests and docs.
> Add filterNot to RDD
> --------------------
>
> Key: SPARK-7028
> URL: https://issues.apache.org/jira/browse/SPARK-7028
> Project: Spark
> Issue Type: Improvement
> Reporter: Marius Soutier
> Priority: Minor
>
> The Scala collection APIs have not only `filter`, but also `filterNot` for convenience and readability. I'd suggest to add the same to RDD.
> I can submit a PR.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org