You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Yu-Chuan Hung (Jira)" <ji...@apache.org> on 2025/10/06 15:35:00 UTC

[jira] [Commented] (HDDS-13232) Remove duplicate code in DirectoryDeletingService

    [ https://issues.apache.org/jira/browse/HDDS-13232?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18027855#comment-18027855 ] 

Yu-Chuan Hung commented on HDDS-13232:
--------------------------------------

Could I give it a try?

> Remove duplicate code in DirectoryDeletingService
> -------------------------------------------------
>
>                 Key: HDDS-13232
>                 URL: https://issues.apache.org/jira/browse/HDDS-13232
>             Project: Apache Ozone
>          Issue Type: Sub-task
>          Components: OM, Snapshot
>            Reporter: Wei-Chiu Chuang
>            Assignee: TengYao Chi
>            Priority: Trivial
>
> optimizeDirDeletesAndSubmitRequest() and processDeletedDirectories() have duplicate code snippet. They can be merged into a helper method.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org