You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Ferenc Csaky (Jira)" <ji...@apache.org> on 2026/01/22 21:21:00 UTC

[jira] [Updated] (FLINK-38799) Rename "LoadingWeight" to "TaskExecutionLoad"

     [ https://issues.apache.org/jira/browse/FLINK-38799?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Ferenc Csaky updated FLINK-38799:
---------------------------------
    Summary: Rename "LoadingWeight" to "TaskExecutionLoad"  (was: Rename "LoadingWeight" to "ResourceUnitCount")

> Rename "LoadingWeight" to "TaskExecutionLoad"
> ---------------------------------------------
>
>                 Key: FLINK-38799
>                 URL: https://issues.apache.org/jira/browse/FLINK-38799
>             Project: Flink
>          Issue Type: Improvement
>          Components: Runtime / Coordination
>            Reporter: Ferenc Csaky
>            Assignee: Ferenc Csaky
>            Priority: Minor
>              Labels: pull-request-available
>             Fix For: 2.3.0
>
>
> The {{LoadingWeight}} interface represents how many units are present in some internal resources at some points of the JM scheduling logic, for example {{ExecutionSlotSharingGroup}}.
> The current naming is misleading and requires quite some search in the code to figure out what is this actually doing. I suggest to rename it to something more intuitive, e.g. {{ResourceUnitCount}}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)