You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Tsz-wo Sze (Jira)" <ji...@apache.org> on 2023/01/13 09:41:00 UTC

[jira] [Assigned] (HDDS-7748) Rename OMFileRequest.addToOpenFileTable() to avoid misuse

     [ https://issues.apache.org/jira/browse/HDDS-7748?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Tsz-wo Sze reassigned HDDS-7748:
--------------------------------

    Assignee: Tsz-wo Sze

> Rename OMFileRequest.addToOpenFileTable() to avoid misuse
> ---------------------------------------------------------
>
>                 Key: HDDS-7748
>                 URL: https://issues.apache.org/jira/browse/HDDS-7748
>             Project: Apache Ozone
>          Issue Type: Sub-task
>          Components: OM
>            Reporter: Wei-Chiu Chuang
>            Assignee: Tsz-wo Sze
>            Priority: Major
>
> This is a badly named API.
> OMFileRequest.addToOpenFileTable() is specifically designed for S3 multipart upload, 
> {code}
> /**
>  * Adding multipart omKeyInfo to open file table.
>  *
>  *@paramomMetadataMgrOM Metadata Manager
>  *@parambatchOpbatch of db operations
>  *@paramomFileInfoomKeyInfo
>  *@paramuploadIDuploadID
>  *@returnmultipartFileKey
>  *@throwsIOException DB failure
>  */
> public static String addToOpenFileTable(OMMetadataManager omMetadataMgr,
>     BatchOperation batchOp, OmKeyInfo omFileInfo, String uploadID,
>     long volumeId, long bucketId) throws IOException {
> {code}
> Adding to open file table for non-multipart upload and multipart upload are different. Please rename this API to avoid misuse in the future.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org