You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@bigtop.apache.org by "Mark Grover (JIRA)" <ji...@apache.org> on 2014/01/21 02:24:20 UTC
[jira] [Commented] (BIGTOP-1187) Spark service packages have
extraneous core in the name
[ https://issues.apache.org/jira/browse/BIGTOP-1187?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13877071#comment-13877071 ]
Mark Grover commented on BIGTOP-1187:
-------------------------------------
Hi Sean, great find, thanks! and sorry that I missed it in my previous patch.
The patch mostly looks good to me. However, I personally prefer the service_macro macro to not have any "spark" for maintainability purposes. One way to do that would be to pass the full name of the service to the macro e.g. spark-worker and spark-core. We do something similar for hcatalog so maybe it makes sense to do the same here for consistency:
https://github.com/apache/bigtop/blob/master/bigtop-packages/src/rpm/hcatalog/SPECS/hcatalog.spec#L164
Let me know what you think. And, thanks again!
> Spark service packages have extraneous core in the name
> -------------------------------------------------------
>
> Key: BIGTOP-1187
> URL: https://issues.apache.org/jira/browse/BIGTOP-1187
> Project: Bigtop
> Issue Type: Bug
> Reporter: Sean Mackrory
> Assignee: Sean Mackrory
> Attachments: 0001-BIGTOP-1187.-Spark-service-packages-have-extraneous-.patch
>
>
> The recent rename of the "spark" package to "spark-core" resulted in the RPMs for service scripts (e.g. "spark-master" and "spark-worker") having an extraneous "core" in the name (e.g. "spark-core-master" and "spark-core-worker"). As the Debian control file indicates, this is not the intended full name of the RPM.
--
This message was sent by Atlassian JIRA
(v6.1.5#6160)