You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ratis.apache.org by "JiangHua Zhu (Jira)" <ji...@apache.org> on 2025/05/06 06:46:00 UTC
[jira] [Created] (RATIS-2287) Improve RaftServerImpl#toString() to make it more readable
JiangHua Zhu created RATIS-2287:
-----------------------------------
Summary: Improve RaftServerImpl#toString() to make it more readable
Key: RATIS-2287
URL: https://issues.apache.org/jira/browse/RATIS-2287
Project: Ratis
Issue Type: Improvement
Components: server
Affects Versions: 3.1.2, 3.1.1
Reporter: JiangHua Zhu
When we print RaftServerImpl, here is some information output:
{code:java}
LEADER s0@group-19104963FACE:t1, leader=s0, voted=s0, raftlog=Memoized:s0@group-19104963FACE-SegmentedRaftLog:OPENED:c0:last(t:1, i:0), conf=conf: {index: 0, cur=peers:[s0|localhost:15000]|listeners:[], old=null} RUNNING
{code}
We can improve toString() to make it more readable.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)