You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ambari.apache.org by "Nate Cole (JIRA)" <ji...@apache.org> on 2013/09/27 21:10:03 UTC

[jira] [Updated] (AMBARI-3364) Refactor the Role enum into a regular class

     [ https://issues.apache.org/jira/browse/AMBARI-3364?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Nate Cole updated AMBARI-3364:
------------------------------

    Description: In order to facilitate new services without having to change code, move the {{Role}} enum to a class.  Add's "enum like" methods to it to maintain existing code as much as possible: such as static {{values()}}, {{valueOf(String)}} and non-static {{name()}}  (was: In order to facilitate new services without having to change code, move the {{Role}} enum to a class.  Add's "enum like" methods to it to maintain existing code as much as possible.)
    
> Refactor the Role enum into a regular class
> -------------------------------------------
>
>                 Key: AMBARI-3364
>                 URL: https://issues.apache.org/jira/browse/AMBARI-3364
>             Project: Ambari
>          Issue Type: Task
>          Components: controller
>            Reporter: Nate Cole
>            Assignee: Nate Cole
>             Fix For: 1.5.1
>
>
> In order to facilitate new services without having to change code, move the {{Role}} enum to a class.  Add's "enum like" methods to it to maintain existing code as much as possible: such as static {{values()}}, {{valueOf(String)}} and non-static {{name()}}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira