You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hama.apache.org by "Edward J. Yoon (JIRA)" <ji...@apache.org> on 2008/08/21 15:42:48 UTC

[jira] Created: (HAMA-40) Rename MatrixInterface to Matrix

Rename MatrixInterface to Matrix
--------------------------------

                 Key: HAMA-40
                 URL: https://issues.apache.org/jira/browse/HAMA-40
             Project: Hama
          Issue Type: Improvement
          Components: interface
            Reporter: Edward J. Yoon
             Fix For: 0.1.0


MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HAMA-40) Rename MatrixInterface to Matrix

Posted by "Edward J. Yoon (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HAMA-40?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12625344#action_12625344 ] 

Edward J. Yoon commented on HAMA-40:
------------------------------------

newPatchFindbugsWarnings.html link seems broken.

> Rename MatrixInterface to Matrix
> --------------------------------
>
>                 Key: HAMA-40
>                 URL: https://issues.apache.org/jira/browse/HAMA-40
>             Project: Hama
>          Issue Type: Improvement
>          Components: interface
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>         Attachments: HAMA-40.patch
>
>
> MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (HAMA-40) Rename MatrixInterface to Matrix

Posted by "Edward J. Yoon (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-40?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Edward J. Yoon resolved HAMA-40.
--------------------------------

    Resolution: Fixed

Findbugs warnings will be handled on HAMA-44.
I'm committed this.

> Rename MatrixInterface to Matrix
> --------------------------------
>
>                 Key: HAMA-40
>                 URL: https://issues.apache.org/jira/browse/HAMA-40
>             Project: Hama
>          Issue Type: Improvement
>          Components: interface
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>         Attachments: HAMA-40.patch
>
>
> MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-40) Rename MatrixInterface to Matrix

Posted by "Edward J. Yoon (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-40?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Edward J. Yoon updated HAMA-40:
-------------------------------

    Attachment: HAMA-40.patch

> Rename MatrixInterface to Matrix
> --------------------------------
>
>                 Key: HAMA-40
>                 URL: https://issues.apache.org/jira/browse/HAMA-40
>             Project: Hama
>          Issue Type: Improvement
>          Components: interface
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>         Attachments: HAMA-40.patch
>
>
> MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-40) Rename MatrixInterface to Matrix

Posted by "Edward J. Yoon (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-40?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Edward J. Yoon updated HAMA-40:
-------------------------------

    Status: Open  (was: Patch Available)

> Rename MatrixInterface to Matrix
> --------------------------------
>
>                 Key: HAMA-40
>                 URL: https://issues.apache.org/jira/browse/HAMA-40
>             Project: Hama
>          Issue Type: Improvement
>          Components: interface
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>         Attachments: HAMA-40.patch
>
>
> MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (HAMA-40) Rename MatrixInterface to Matrix

Posted by "Edward J. Yoon (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-40?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Edward J. Yoon reassigned HAMA-40:
----------------------------------

    Assignee: Edward J. Yoon

> Rename MatrixInterface to Matrix
> --------------------------------
>
>                 Key: HAMA-40
>                 URL: https://issues.apache.org/jira/browse/HAMA-40
>             Project: Hama
>          Issue Type: Improvement
>          Components: interface
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>
> MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HAMA-40) Rename MatrixInterface to Matrix

Posted by "Edward J. Yoon (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HAMA-40?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Edward J. Yoon updated HAMA-40:
-------------------------------

    Status: Patch Available  (was: In Progress)

Submitting.

> Rename MatrixInterface to Matrix
> --------------------------------
>
>                 Key: HAMA-40
>                 URL: https://issues.apache.org/jira/browse/HAMA-40
>             Project: Hama
>          Issue Type: Improvement
>          Components: interface
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>         Attachments: HAMA-40.patch
>
>
> MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HAMA-40) Rename MatrixInterface to Matrix

Posted by "Hudson (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HAMA-40?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12625340#action_12625340 ] 

Hudson commented on HAMA-40:
----------------------------

-1 overall.  Here are the results of testing the latest attachment 
http://issues.apache.org/jira/secure/attachment/12388830/HAMA-40.patch
against trunk revision 688707.

    @author +1.  The patch does not contain any @author tags.

    tests included +1.  The patch appears to include 9 new or modified tests.

    javadoc +1.  The javadoc tool did not generate any warning messages.

    javac +1.  The applied patch does not generate any new javac compiler warnings.

    release audit +1.  The applied patch does not generate any new release audit warnings.

    findbugs -1.  The patch appears to introduce 5 new Findbugs warnings.

    core tests +1.  The patch passed core unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hama-Patch/43/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hama-Patch/43/artifact/trunk/build/reports/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hama-Patch/43/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hama-Patch/43/console

This message is automatically generated.

> Rename MatrixInterface to Matrix
> --------------------------------
>
>                 Key: HAMA-40
>                 URL: https://issues.apache.org/jira/browse/HAMA-40
>             Project: Hama
>          Issue Type: Improvement
>          Components: interface
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>         Attachments: HAMA-40.patch
>
>
> MatrixInterface should be Matrix. And, Implement could be ***Matrix (e.g. DenseMatrix,...,etc)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.