You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Jing Zhao (JIRA)" <ji...@apache.org> on 2014/02/01 00:48:13 UTC
[jira] [Updated] (HDFS-5860) Refactor INodeDirectory
getDirectoryXFeature methods to use common getFeature helper method.
[ https://issues.apache.org/jira/browse/HDFS-5860?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Jing Zhao updated HDFS-5860:
----------------------------
Attachment: HDFS-5860.000.patch
> Refactor INodeDirectory getDirectoryXFeature methods to use common getFeature helper method.
> --------------------------------------------------------------------------------------------
>
> Key: HDFS-5860
> URL: https://issues.apache.org/jira/browse/HDFS-5860
> Project: Hadoop HDFS
> Issue Type: Improvement
> Components: namenode
> Affects Versions: HDFS ACLs (HDFS-4685)
> Reporter: Chris Nauroth
> Assignee: Jing Zhao
> Priority: Minor
> Attachments: HDFS-5860.000.patch
>
>
> The HDFS-4685 feature branch has introduced a helper method for getting an inode feature of a particular class: {{INodeWithAdditionalFields#getFeature}}. Currently, this is only called by code related to ACLs, but we can also use the same method to reduce code duplication in the various {{INodeDirectory}} methods that get different kinds of features.
--
This message was sent by Atlassian JIRA
(v6.1.5#6160)