You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@qpid.apache.org by Rajika Kumarasiri <ra...@wso2.com> on 2010/05/15 16:04:09 UTC

Re-factoring shell/batch scripts in bin directory

When I first build Qpid java broker and looked inside the bin folder I was
confused. This happens due to the fact there are lot of scripts which I
couldn't figure out what they do by looking at their names. ( Next thing I
did was to check README.txt which really didn't help to figure out what the
scripts does). I suggest we do some re-factoring on these scripts.
1. Have self descriptive names for the scripts ( so that one can figure out
which scripts to run by seeing the name). For instance which is the first
script to run qpid-run, qpid-server.
2. Move the utility scripts such as setenv, set_classpath to a util
directory inside bin directory.
3. Move client/examples scripts to client/examples directory.
4. Use a consistent naming convention when naming the script. See
topicListener.sh, run_sub.sh, qpid-run etc..
5. Add a compressive README.txt if required.

Rajika

-- 
http://rajikak.blogspot.com/

Re: Re-factoring shell/batch scripts in bin directory

Posted by "Sorin S." <ss...@gmail.com>.
Hi Andrew,
+1 for storing the PID, I will submit a patch for this shortly.

Thanks,

Sorin


On Wed, May 19, 2010 at 11:03 AM, Andrew Kennedy <
andrewinternational@gmail.com> wrote:

> On 15 May 2010 15:04, Rajika Kumarasiri <ra...@wso2.com> wrote:
> > When I first build Qpid java broker and looked inside the bin folder I
> was
> > confused. This happens due to the fact there are lot of scripts which I
> > couldn't figure out what they do by looking at their names. ( Next thing
> I
> > did was to check README.txt which really didn't help to figure out what
> the
> > scripts does). I suggest we do some re-factoring on these scripts.
> > 1. Have self descriptive names for the scripts ( so that one can figure
> out
> > which scripts to run by seeing the name). For instance which is the first
> > script to run qpid-run, qpid-server.
> > 2. Move the utility scripts such as setenv, set_classpath to a util
> > directory inside bin directory.
> > 3. Move client/examples scripts to client/examples directory.
> > 4. Use a consistent naming convention when naming the script. See
> > topicListener.sh, run_sub.sh, qpid-run etc..
> > 5. Add a compressive README.txt if required.
>
> If anyone is doing this, it might be an idea to make some startup
> scripts that are rc.d compatible, such that they can take
> start/stop/restart as the first argument, and also store the broker
> pid in a file?
>
> adk.
> --
> -- andrew d kennedy ? edinburgh : +44 7941 197 134
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>
>


-- 
Sorin S

Re: Re-factoring shell/batch scripts in bin directory

Posted by Marnie McCormack <ma...@googlemail.com>.
The pid prefix/suffix log props use the broker PID to be used on the log
file naming (google qpid-run). We could easily add the storing of the PID -
but what for, process locking ?

Marnie

On Wed, May 19, 2010 at 11:03 AM, Andrew Kennedy <
andrewinternational@gmail.com> wrote:

>  On 15 May 2010 15:04, Rajika Kumarasiri <ra...@wso2.com> wrote:
> > When I first build Qpid java broker and looked inside the bin folder I
> was
> > confused. This happens due to the fact there are lot of scripts which I
> > couldn't figure out what they do by looking at their names. ( Next thing
> I
> > did was to check README.txt which really didn't help to figure out what
> the
> > scripts does). I suggest we do some re-factoring on these scripts.
> > 1. Have self descriptive names for the scripts ( so that one can figure
> out
> > which scripts to run by seeing the name). For instance which is the first
> > script to run qpid-run, qpid-server.
> > 2. Move the utility scripts such as setenv, set_classpath to a util
> > directory inside bin directory.
> > 3. Move client/examples scripts to client/examples directory.
> > 4. Use a consistent naming convention when naming the script. See
> > topicListener.sh, run_sub.sh, qpid-run etc..
> > 5. Add a compressive README.txt if required.
>
> If anyone is doing this, it might be an idea to make some startup
> scripts that are rc.d compatible, such that they can take
> start/stop/restart as the first argument, and also store the broker
> pid in a file?
>
> adk.
> --
> -- andrew d kennedy ? edinburgh : +44 7941 197 134
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>
>

Re: Re-factoring shell/batch scripts in bin directory

Posted by Rajika Kumarasiri <ra...@wso2.com>.
On Wed, May 19, 2010 at 3:33 PM, Andrew Kennedy <
andrewinternational@gmail.com> wrote:

> On 15 May 2010 15:04, Rajika Kumarasiri <ra...@wso2.com> wrote:
> > When I first build Qpid java broker and looked inside the bin folder I
> was
> > confused. This happens due to the fact there are lot of scripts which I
> > couldn't figure out what they do by looking at their names. ( Next thing
> I
> > did was to check README.txt which really didn't help to figure out what
> the
> > scripts does). I suggest we do some re-factoring on these scripts.
> > 1. Have self descriptive names for the scripts ( so that one can figure
> out
> > which scripts to run by seeing the name). For instance which is the first
> > script to run qpid-run, qpid-server.
> > 2. Move the utility scripts such as setenv, set_classpath to a util
> > directory inside bin directory.
> > 3. Move client/examples scripts to client/examples directory.
> > 4. Use a consistent naming convention when naming the script. See
> > topicListener.sh, run_sub.sh, qpid-run etc..
> > 5. Add a compressive README.txt if required.
>
> If anyone is doing this, it might be an idea to make some startup
> scripts that are rc.d compatible, such that they can take
> start/stop/restart as the first argument, and also store the broker
> pid in a file?
>
> + 1 for making the scripts consistent and rc.d compatible.

Rajika

-- 
http://rajikak.blogspot.com/

Re: Re-factoring shell/batch scripts in bin directory

Posted by Andrew Kennedy <an...@gmail.com>.
On 15 May 2010 15:04, Rajika Kumarasiri <ra...@wso2.com> wrote:
> When I first build Qpid java broker and looked inside the bin folder I was
> confused. This happens due to the fact there are lot of scripts which I
> couldn't figure out what they do by looking at their names. ( Next thing I
> did was to check README.txt which really didn't help to figure out what the
> scripts does). I suggest we do some re-factoring on these scripts.
> 1. Have self descriptive names for the scripts ( so that one can figure out
> which scripts to run by seeing the name). For instance which is the first
> script to run qpid-run, qpid-server.
> 2. Move the utility scripts such as setenv, set_classpath to a util
> directory inside bin directory.
> 3. Move client/examples scripts to client/examples directory.
> 4. Use a consistent naming convention when naming the script. See
> topicListener.sh, run_sub.sh, qpid-run etc..
> 5. Add a compressive README.txt if required.

If anyone is doing this, it might be an idea to make some startup
scripts that are rc.d compatible, such that they can take
start/stop/restart as the first argument, and also store the broker
pid in a file?

adk.
-- 
-- andrew d kennedy ? edinburgh : +44 7941 197 134

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Re: Re-factoring shell/batch scripts in bin directory

Posted by Rajika Kumarasiri <ra...@wso2.com>.
On Tue, May 18, 2010 at 8:43 PM, Marnie McCormack <
marnie.mccormack@googlemail.com> wrote:

> Hi Rajika,
>

hi,


> I definitely don't have a strong view on version numbering but Qpid has
> been
> in prod across a host of applications for years now.
>
> Qpid has real users transitting business critical data all round the world.
>

This is really good news.

Rajika

Re: Re-factoring shell/batch scripts in bin directory

Posted by Marnie McCormack <ma...@googlemail.com>.
Hi Rajika,

I definitely don't have a strong view on version numbering but Qpid has been
in prod across a host of applications for years now.

Qpid has real users transitting business critical data all round the world.

Marnie
On Tue, May 18, 2010 at 4:08 PM, Rajika Kumarasiri <ra...@wso2.com> wrote:

> On Tue, May 18, 2010 at 8:18 PM, Marnie McCormack <
> marnie.mccormack@googlemail.com> wrote:
>
> > Hi Rajika,
> >
>
> hi,
>
> >
> > Thanks for your email.
> >
> > There are docs for these scripts on the wiki:
> >
> > http://qpid.apache.org/qpid-java-run-scripts.html
> >
> > Please do *not* change any of the broker script names as we have
> production
> > apps for whom this would be a major pita !
> >
>
> Ok, I thought this become production ready when the major number >= 1
> according to the specification( see 1.5.2 Version numbering).
>
> >
> > A readme would be a great idea, hopefully the wiki content is helpful
> here.
> >
>
> I'll submit a patch for the read me.
>
> >
> > On the bin/util dir - is this for the client package ?
> >
>
> What I meant was for utility scripts such as setenv.sh, set_classpath.sh
> etc...
> It seems that we can live with a README.txt for now.
>
> Rajika
>
> >
> > Thanks,
> > Marnie
> >
> > On Sat, May 15, 2010 at 3:04 PM, Rajika Kumarasiri <ra...@wso2.com>
> > wrote:
> >
> > > When I first build Qpid java broker and looked inside the bin folder I
> > was
> > > confused. This happens due to the fact there are lot of scripts which I
> > > couldn't figure out what they do by looking at their names. ( Next
> thing
> > I
> > > did was to check README.txt which really didn't help to figure out what
> > the
> > > scripts does). I suggest we do some re-factoring on these scripts.
> > > 1. Have self descriptive names for the scripts ( so that one can figure
> > out
> > > which scripts to run by seeing the name). For instance which is the
> first
> > > script to run qpid-run, qpid-server.
> > > 2. Move the utility scripts such as setenv, set_classpath to a util
> > > directory inside bin directory.
> > > 3. Move client/examples scripts to client/examples directory.
> > > 4. Use a consistent naming convention when naming the script. See
> > > topicListener.sh, run_sub.sh, qpid-run etc..
> > > 5. Add a compressive README.txt if required.
> > >
> > > Rajika
> > >
> > > --
> > > http://rajikak.blogspot.com/
> > >
> >
>
>
>
> --
> http://rajikak.blogspot.com/
>

Re: Re-factoring shell/batch scripts in bin directory

Posted by Rajika Kumarasiri <ra...@wso2.com>.
On Tue, May 18, 2010 at 8:18 PM, Marnie McCormack <
marnie.mccormack@googlemail.com> wrote:

> Hi Rajika,
>

hi,

>
> Thanks for your email.
>
> There are docs for these scripts on the wiki:
>
> http://qpid.apache.org/qpid-java-run-scripts.html
>
> Please do *not* change any of the broker script names as we have production
> apps for whom this would be a major pita !
>

Ok, I thought this become production ready when the major number >= 1
according to the specification( see 1.5.2 Version numbering).

>
> A readme would be a great idea, hopefully the wiki content is helpful here.
>

I'll submit a patch for the read me.

>
> On the bin/util dir - is this for the client package ?
>

What I meant was for utility scripts such as setenv.sh, set_classpath.sh
etc...
It seems that we can live with a README.txt for now.

Rajika

>
> Thanks,
> Marnie
>
> On Sat, May 15, 2010 at 3:04 PM, Rajika Kumarasiri <ra...@wso2.com>
> wrote:
>
> > When I first build Qpid java broker and looked inside the bin folder I
> was
> > confused. This happens due to the fact there are lot of scripts which I
> > couldn't figure out what they do by looking at their names. ( Next thing
> I
> > did was to check README.txt which really didn't help to figure out what
> the
> > scripts does). I suggest we do some re-factoring on these scripts.
> > 1. Have self descriptive names for the scripts ( so that one can figure
> out
> > which scripts to run by seeing the name). For instance which is the first
> > script to run qpid-run, qpid-server.
> > 2. Move the utility scripts such as setenv, set_classpath to a util
> > directory inside bin directory.
> > 3. Move client/examples scripts to client/examples directory.
> > 4. Use a consistent naming convention when naming the script. See
> > topicListener.sh, run_sub.sh, qpid-run etc..
> > 5. Add a compressive README.txt if required.
> >
> > Rajika
> >
> > --
> > http://rajikak.blogspot.com/
> >
>



-- 
http://rajikak.blogspot.com/

Re: Re-factoring shell/batch scripts in bin directory

Posted by Marnie McCormack <ma...@googlemail.com>.
Hi Rajika,

Thanks for your email.

There are docs for these scripts on the wiki:

http://qpid.apache.org/qpid-java-run-scripts.html

Please do *not* change any of the broker script names as we have production
apps for whom this would be a major pita !

A readme would be a great idea, hopefully the wiki content is helpful here.

On the bin/util dir - is this for the client package ?

Thanks,
Marnie

On Sat, May 15, 2010 at 3:04 PM, Rajika Kumarasiri <ra...@wso2.com> wrote:

> When I first build Qpid java broker and looked inside the bin folder I was
> confused. This happens due to the fact there are lot of scripts which I
> couldn't figure out what they do by looking at their names. ( Next thing I
> did was to check README.txt which really didn't help to figure out what the
> scripts does). I suggest we do some re-factoring on these scripts.
> 1. Have self descriptive names for the scripts ( so that one can figure out
> which scripts to run by seeing the name). For instance which is the first
> script to run qpid-run, qpid-server.
> 2. Move the utility scripts such as setenv, set_classpath to a util
> directory inside bin directory.
> 3. Move client/examples scripts to client/examples directory.
> 4. Use a consistent naming convention when naming the script. See
> topicListener.sh, run_sub.sh, qpid-run etc..
> 5. Add a compressive README.txt if required.
>
> Rajika
>
> --
> http://rajikak.blogspot.com/
>