You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Nanda kumar (JIRA)" <ji...@apache.org> on 2018/04/02 13:56:00 UTC

[jira] [Commented] (HDFS-13348) Ozone: Update IP and hostname in Datanode from SCM's response to the register call

    [ https://issues.apache.org/jira/browse/HDFS-13348?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16422530#comment-16422530 ] 

Nanda kumar commented on HDFS-13348:
------------------------------------

Thanks [~shashikant] for working on this. Please find the review comments below.

*StorageContainerDatanodeProtocol.proto*
nitpick: hostName can be rename to hostname.

*RegisteredCommand.java*
nitpick: hostName can be renamed to hostname.
Line 190 & 195: There is no need for null check here. If setHostName & setIpAddress methods are not called the value of hostName & ipAddress will be null.

*RegisterEndpointTask.java*
Not related to the change done in this jira: Line:90 The error message is wrong.

*SCMNodeManager.java*
Line:803 & 804 hostname and ip are not always set. When {{Server.getRemoteIp()}} returns null (i.e. if the method is not called inside an RPC) the value of hostname and ip will be null. This case has to be handled.

> Ozone: Update IP and hostname in Datanode from SCM's response to the register call
> ----------------------------------------------------------------------------------
>
>                 Key: HDFS-13348
>                 URL: https://issues.apache.org/jira/browse/HDFS-13348
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ozone
>            Reporter: Nanda kumar
>            Assignee: Shashikant Banerjee
>            Priority: Major
>         Attachments: HDFS-13348-HDFS-7240.000.patch
>
>
> Whenever a Datanode registers with SCM, the SCM resolves the IP address and hostname of the Datanode form the RPC call. This IP address and hostname should be sent back to Datanode in the response to register call and the Datanode has to update the values from the response to its {{DatanodeDetails}}.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org