You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Fabian Hueske (JIRA)" <ji...@apache.org> on 2017/05/07 13:52:04 UTC
[jira] [Closed] (FLINK-6257) Post-pass OVER windows
[ https://issues.apache.org/jira/browse/FLINK-6257?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Fabian Hueske closed FLINK-6257.
--------------------------------
Resolution: Done
Fix Version/s: 1.3.0
Done with 9f2293cfdab960246fe1aea1d705eea18a011761
> Post-pass OVER windows
> ----------------------
>
> Key: FLINK-6257
> URL: https://issues.apache.org/jira/browse/FLINK-6257
> Project: Flink
> Issue Type: Sub-task
> Components: Table API & SQL
> Affects Versions: 1.3.0
> Reporter: Fabian Hueske
> Assignee: sunjincheng
> Priority: Critical
> Fix For: 1.3.0
>
>
> The OVER windows have been implemented by several contributors.
> We should do a post pass over the contributed code and improve a few things.
> * Functionality
> ** Currently every time attribute is allowed as ORDER BY attribute. We must check that this is actually a time indicator ({{procTime()}}, {{rowTime()}}) and that the order is ASCENDING.
> * Documentation
> ** Add documentation for OVER windows
> * Code style
> ** Consistent naming of {{ProcessFunctions}} and methods
> * Tests
> ** Move the OVER window tests out of SqlITCase into a dedicated class
> ** Move the OVER window tests out of WindowAggregateTest into a dedicated class
> ** Add tests based on the test harness for all {{ProcessFunctions}} similar to {{BoundedProcessingOverRangeProcessFunction}}. The tests should include exact boundary checks for range windows and check for proper parallelization with multiple keys.
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)