You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "stack (JIRA)" <ji...@apache.org> on 2010/07/22 22:15:52 UTC

[jira] Created: (HBASE-2865) Cleanup of LRU logging; its hard to read, uses custom MB'maker, repeats info, too many numbers after the point, etc.

Cleanup of LRU logging; its hard to read, uses custom MB'maker, repeats info, too many numbers after the point, etc.
--------------------------------------------------------------------------------------------------------------------

                 Key: HBASE-2865
                 URL: https://issues.apache.org/jira/browse/HBASE-2865
             Project: HBase
          Issue Type: Improvement
            Reporter: stack
             Fix For: 0.90.0


Sorry, I got stuck on this.  I wanted to clear the LRU logging from the log but I suppose its of use... then I started to study it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (HBASE-2865) Cleanup of LRU logging; its hard to read, uses custom MB'maker, repeats info, too many numbers after the point, etc.

Posted by "stack (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HBASE-2865?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

stack resolved HBASE-2865.
--------------------------

    Resolution: Fixed

I just committed.  Just changes logging format though I did change a method signature having it return a LinkedList instead of an array:

{code}
-  public CachedBlock [] get() {
+  public LinkedList<CachedBlock> get() {
{code}

... to save on an array creation.

Tests still pass.

> Cleanup of LRU logging; its hard to read, uses custom MB'maker, repeats info, too many numbers after the point, etc.
> --------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-2865
>                 URL: https://issues.apache.org/jira/browse/HBASE-2865
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: stack
>             Fix For: 0.90.0
>
>         Attachments: 2865.txt
>
>
> Sorry, I got stuck on this.  I wanted to clear the LRU logging from the log but I suppose its of use... then I started to study it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HBASE-2865) Cleanup of LRU logging; its hard to read, uses custom MB'maker, repeats info, too many numbers after the point, etc.

Posted by "stack (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HBASE-2865?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

stack updated HBASE-2865:
-------------------------

    Attachment: 2865.txt

> Cleanup of LRU logging; its hard to read, uses custom MB'maker, repeats info, too many numbers after the point, etc.
> --------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-2865
>                 URL: https://issues.apache.org/jira/browse/HBASE-2865
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: stack
>             Fix For: 0.90.0
>
>         Attachments: 2865.txt
>
>
> Sorry, I got stuck on this.  I wanted to clear the LRU logging from the log but I suppose its of use... then I started to study it.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.