You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@tajo.apache.org by "Hyunsik Choi (JIRA)" <ji...@apache.org> on 2014/09/21 21:24:35 UTC
[jira] [Updated] (TAJO-323) Refactor inconsistent class and
variable names
[ https://issues.apache.org/jira/browse/TAJO-323?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Hyunsik Choi updated TAJO-323:
------------------------------
Fix Version/s: (was: 0.9.0)
> Refactor inconsistent class and variable names
> ----------------------------------------------
>
> Key: TAJO-323
> URL: https://issues.apache.org/jira/browse/TAJO-323
> Project: Tajo
> Issue Type: Task
> Reporter: Hyunsik Choi
>
> There are inconsistent class and variable names. For example, QueryUnit and task are used in a mixing way, and QueryUnitAttempt and taskattempt are used in a mixing way. They reduce readability and make developers confuse.
> Now is the right time to correct them. The main object of this issue is to investigate those inconsistent class and variable names and correct them.
> However, this work may make many conflicts. In order to minimize the code conflict, we need to make a number of small separate refactors.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)