You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@harmony.apache.org by Jean-frederic Clere <jf...@telefonica.net> on 2005/10/31 23:47:46 UTC

[BootJVM] jvm/src/opcode.c patch

Hi,

I would like to propose the following patch:
+++
jfclere@jfcexpert:~/harmony/enhanced/trunk/sandbox/contribs/bootjvm/bootJVM> 
svn diff jvm/src/opcode.c
Index: jvm/src/opcode.c
===================================================================
--- jvm/src/opcode.c    (revision 329310)
+++ jvm/src/opcode.c    (working copy)
@@ -985,7 +985,7 @@
  * creating better readability of the code.
  */

-static void dummy1(void) { char *p, *dummy2; dummy2 = p; dummy1(); }
+static void dummy1(void) { void (*p)()=NULL; p(); }
 #define STUB { dummy1(); }

 switch(opcode)
+++
The idea is to core ASAP when we reach a not yet supported opcode, any 
comment?

Cheers

Jean-Frederic