You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Charles Xu (JIRA)" <ji...@apache.org> on 2019/07/19 15:39:00 UTC

[jira] [Updated] (FLINK-13130) Refactor AbstractYarnClusterDescriptor to reduce code duplication

     [ https://issues.apache.org/jira/browse/FLINK-13130?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Charles Xu updated FLINK-13130:
-------------------------------
    Summary: Refactor AbstractYarnClusterDescriptor to reduce code duplication  (was: Refactor AbstractYarnClusterDescriptor to avoid code duplication)

> Refactor AbstractYarnClusterDescriptor to reduce code duplication
> -----------------------------------------------------------------
>
>                 Key: FLINK-13130
>                 URL: https://issues.apache.org/jira/browse/FLINK-13130
>             Project: Flink
>          Issue Type: Improvement
>          Components: Deployment / YARN
>    Affects Versions: 1.8.0, 1.8.1
>            Reporter: Charles Xu
>            Priority: Minor
>              Labels: pull-request-available
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> There are two places that checks environment variable (HADOO_CONF_DIR or YARN_CONF_DIR).
> It's better to extract one method to avoid code duplication. 
> {code:java}
> // check if required Hadoop environment variables are set. If not, warn user
> private void checkEnvironmentVariable() {
>     if (System.getenv("HADOOP_CONF_DIR") == null &&
>         System.getenv("YARN_CONF_DIR") == null) {
>             LOG.warn("Neither the HADOOP_CONF_DIR nor the YARN_CONF_DIR environment variable is set. " +
>                 "The Flink YARN Client needs one of these to be set to properly load the Hadoop " +
>                 "configuration for accessing YARN.");
>     }
> }
> {code}
>  



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)