You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Jeremias Maerki <de...@greenmail.ch> on 2003/07/03 17:34:08 UTC

[IO] my plans, please comment

Thanks to everyone involved. I've finally got write access to IO.

As a first move I've applied my patch #18707. I considered this a safe
move so I just went ahead. So now to the real business. I'd like to do
the following things:

- IOUtil: Remove the toByteArray() variants with the bufferSize
  parameter. Reasoning can be found at [1]. I didn't get any answers on
  that one.

- IOUtil: Change toByteArray() methods to use the new
  ByteArrayOutputStream which should improve performance considerably.

- IOUtil: Remove the deprecated bufferedCopy method. IO is not released
  so we should be able to do that.

- Setup a website to attract more people and to prepare for a release.

- Rename FileUtils to FileUtil for consistency.

- FileUtil(s): Add isFileNewer() method from Alban Peignier [2].

Additional ideas:
- Add an additional ByteArrayOutputStream variant that saves content
  in memory just as the original but starts to write to a temp file when
  a given number of bytes is surpassed. This is to reduce the memory
  usage for big "things".

For reference, I've just looked up what projects/modules are currently showing
as depedant on Commons IO in Gump:
- commons-xo
- db-torque
- jakarta-turbine-3
- jakarta-turbine-stratum
- jakarta-turbine-stratum-full
- maven
- maven-bootstrap
- xml-fop 

What needs to be done to bring IO to release readiness?

What I see is:
- Many classes need test cases (I'll try to write some)
- filefilter, input and output packages look pretty good, probably need
  some occasional documentation touch-up.
- I don't know about the compress package. There's bzip2 in a separate
  sub-subproject. Ant also still has classes for bzip/zip/tar. I think
  these parts should be consolidated in a separate compress project.


I'm hoping for comments and additional ideas.


Jeremias Maerki


[1] http://www.mail-archive.com/commons-dev@jakarta.apache.org/msg19703.html
[2] http://nagoya.apache.org/eyebrowse/BrowseList?listName=commons-dev@jakarta.apache.org&by=thread&from=348688

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [IO] my plans, please comment

Posted by Jeremias Maerki <de...@greenmail.ch>.
Oops, I didn't realize that. Thanks for pointing that out.

Ok, so we got another todo instead:
- Rename all *Util.java to *Utils.java for consistency.

BTW: I'll be out of touch until next Friday.

On 05.07.2003 16:32:56 Stephen Colebourne wrote:
> From: "Jeremias Maerki" <de...@greenmail.ch>
> > - Rename FileUtils to FileUtil for consistency.
> 
> In fact, its IOUtil that is wrong. All jakarta-commons utility classes end
> in Utils.



Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [IO] my plans, please comment

Posted by Stephen Colebourne <sc...@btopenworld.com>.
From: "Jeremias Maerki" <de...@greenmail.ch>
> - Rename FileUtils to FileUtil for consistency.

In fact, its IOUtil that is wrong. All jakarta-commons utility classes end
in Utils.

Stephen


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [IO] my plans, please comment

Posted by Jeremias Maerki <de...@greenmail.ch>.
On 06.07.2003 17:13:26 Henri Yandell wrote:
> On Thu, 3 Jul 2003, Jeremias Maerki wrote:
> 
> > - Setup a website to attract more people and to prepare for a release.
> 
> Let me know if you need help with this.

Thanks.

<snip/>

> > What needs to be done to bring IO to release readiness?
> >
> > What I see is:
> > - Many classes need test cases (I'll try to write some)
> > - filefilter, input and output packages look pretty good, probably need
> >   some occasional documentation touch-up.
> > - I don't know about the compress package. There's bzip2 in a separate
> >   sub-subproject. Ant also still has classes for bzip/zip/tar. I think
> >   these parts should be consolidated in a separate compress project.
> 
> Compress should be pulled out I agree. Have you noticed the list of todo's
> in STATUS.html?

Nope. :-O But looking at them, they seem confusing:
"Compress - Move the compress sub-package out of IO - READY"

What does "READY" mean here? Ready to be moved out? Then, does that mean
we can simply start a new package "compress" (or "compression") and move
it there and integrate bzip2? But I guess we should synchronize with the
Ant-people first.

I will add my items to the file.

Jeremias Maerki


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [IO] my plans, please comment

Posted by Henri Yandell <ba...@generationjava.com>.

On Thu, 3 Jul 2003, Jeremias Maerki wrote:

> - Setup a website to attract more people and to prepare for a release.

Let me know if you need help with this.

> Additional ideas:
> - Add an additional ByteArrayOutputStream variant that saves content
>   in memory just as the original but starts to write to a temp file when
>   a given number of bytes is surpassed. This is to reduce the memory
>   usage for big "things".

Sounds good.

> For reference, I've just looked up what projects/modules are currently showing
> as depedant on Commons IO in Gump:
> - commons-xo
> - db-torque
> - jakarta-turbine-3
> - jakarta-turbine-stratum
> - jakarta-turbine-stratum-full
> - maven
> - maven-bootstrap
> - xml-fop

Youch.

> What needs to be done to bring IO to release readiness?
>
> What I see is:
> - Many classes need test cases (I'll try to write some)
> - filefilter, input and output packages look pretty good, probably need
>   some occasional documentation touch-up.
> - I don't know about the compress package. There's bzip2 in a separate
>   sub-subproject. Ant also still has classes for bzip/zip/tar. I think
>   these parts should be consolidated in a separate compress project.

Compress should be pulled out I agree. Have you noticed the list of todo's
in STATUS.html?


Hen


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org