You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@groovy.apache.org by "Eric Milles (Jira)" <ji...@apache.org> on 2026/01/21 13:20:00 UTC

[jira] [Commented] (GROOVY-11000) Unable to load FastStringService in OSGI Environment in Groovy-all: 3.0.11 version

    [ https://issues.apache.org/jira/browse/GROOVY-11000?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18053304#comment-18053304 ] 

Eric Milles commented on GROOVY-11000:
--------------------------------------

The loader was recently changed to provide default string service. I don’t have the issue number at hand. 

> Unable to load FastStringService in OSGI Environment in Groovy-all: 3.0.11 version
> ----------------------------------------------------------------------------------
>
>                 Key: GROOVY-11000
>                 URL: https://issues.apache.org/jira/browse/GROOVY-11000
>             Project: Groovy
>          Issue Type: Bug
>         Environment: Production
>            Reporter: neha
>            Assignee: Paul King
>            Priority: Major
>             Fix For: 3.0.11
>
>         Attachments: cpissue.groovy, groovyissue.PNG
>
>
> After upgrading to 3.0.11, getting attached error in OSGI environment while running a groovy script.
> Its seems same issue has been fixed in 4.0.9 groovy version. (https://issues.apache.org/jira/browse/GROOVY-10881)
> We are using grails and latest grails version also supports groovy - 3.0.11 version. So, we can't upgrade groovy to latest version.
> We need a patch on top of 3.0.11 groovy version.
> Please provide



--
This message was sent by Atlassian Jira
(v8.20.10#820010)