You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flume.apache.org by "Mike Percy (JIRA)" <ji...@apache.org> on 2012/10/12 19:43:03 UTC
[jira] [Updated] (FLUME-1631) Retire hdfs.txnEventMax in HDFS sink
[ https://issues.apache.org/jira/browse/FLUME-1631?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Mike Percy updated FLUME-1631:
------------------------------
Description:
The HDFS sink uses hdfs.txnEventMax in addition to hdfs.batchSize to control number of events taken in a transaction and also regularity of fsync() behavior separately. All other sinks use a single property batchSize to control both of these parameters.
We should use the hdfs.batchSize parameter for both of these things so that the hdfs.txnEventMax parameter does nothing.
was:
The HDFS sink uses hdfs.txnEventSize in addition to hdfs.batchSize to control number of events taken in a transaction and also regularity of fsync() behavior separately. All other sinks use a single property batchSize to control both of these parameters.
We should use the hdfs.batchSize parameter for both of these things so that the hdfs.txnEventSize parameter does nothing.
> Retire hdfs.txnEventMax in HDFS sink
> ------------------------------------
>
> Key: FLUME-1631
> URL: https://issues.apache.org/jira/browse/FLUME-1631
> Project: Flume
> Issue Type: Improvement
> Components: Sinks+Sources
> Reporter: Mike Percy
> Priority: Minor
>
> The HDFS sink uses hdfs.txnEventMax in addition to hdfs.batchSize to control number of events taken in a transaction and also regularity of fsync() behavior separately. All other sinks use a single property batchSize to control both of these parameters.
> We should use the hdfs.batchSize parameter for both of these things so that the hdfs.txnEventMax parameter does nothing.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira