You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Vinod K V (JIRA)" <ji...@apache.org> on 2010/03/10 12:11:28 UTC

[jira] Resolved: (HADOOP-4221) TaskTracker.launchTaskForJob can be moved out of TaskTracker.localizeJob for better readability.

     [ https://issues.apache.org/jira/browse/HADOOP-4221?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Vinod K V resolved HADOOP-4221.
-------------------------------

    Resolution: Duplicate

MAPREDUCE-927 did this trivial refactor.

> TaskTracker.launchTaskForJob can be moved out of TaskTracker.localizeJob for better readability.
> ------------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-4221
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4221
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Vinod K V
>            Priority: Trivial
>
> The following is better readable than what is currently present.
> {code}
> private void startNewTask(tip){
>   jobFile = localizeJob(tip);
>   launchTaskForJob(tip, jobFile);
>   ...
> }
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.