You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Miklos Szegedi (JIRA)" <ji...@apache.org> on 2018/06/20 22:00:00 UTC

[jira] [Commented] (YARN-8438) TestContainer.testKillOnNew flaky on trunk

    [ https://issues.apache.org/jira/browse/YARN-8438?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16518648#comment-16518648 ] 

Miklos Szegedi commented on YARN-8438:
--------------------------------------

Thank you for the patch [~snemeth].
I would choose a better name than CustomMonotonicClock. StrictlyMonotonicClock maybe?
Also the implementation that you gave is actually not monotonic anymore. Let's assume we get a call at 1000. We return 1000. We then call again and get 1000 again then we return 1001. Then we get another call within the same millisecond and get 1000. 1000 does not equal to 1001 at this point, so we will return 1000. The consequence is that the clock will return 1000, 1001 and 1000. This is not monotonic anymore.

> TestContainer.testKillOnNew flaky on trunk
> ------------------------------------------
>
>                 Key: YARN-8438
>                 URL: https://issues.apache.org/jira/browse/YARN-8438
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager
>            Reporter: Szilard Nemeth
>            Assignee: Szilard Nemeth
>            Priority: Major
>         Attachments: YARN-8438.001.patch
>
>
> Running this test several times (e.g. 30), it fails ~5-10 times.
> Stacktrace: 
> {code:java}
> java.lang.AssertionError at org.junit.Assert.fail(Assert.java:86) at org.junit.Assert.assertTrue(Assert.java:41) at org.junit.Assert.assertTrue(Assert.java:52) at org.apache.hadoop.yarn.server.nodemanager.containermanager.container.TestContainer.testKillOnNew(TestContainer.java:594)
> {code}
> TestContainer:594 is the following code in trunk, currently:
> {code:java}
> Assert.assertTrue( containerMetrics.finishTime.value() > containerMetrics.startTime .value());
> {code}
> So sometimes the finish time is not greater than the start time.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org