You are viewing a plain text version of this content. The canonical link for it is here.
Posted to oak-issues@jackrabbit.apache.org by "Michael Dürig (JIRA)" <ji...@apache.org> on 2013/02/27 17:27:12 UTC

[jira] [Resolved] (OAK-609) Rename 'root' methods in NodeStore and NodeStoreBranch

     [ https://issues.apache.org/jira/browse/OAK-609?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Michael Dürig resolved OAK-609.
-------------------------------

       Resolution: Fixed
    Fix Version/s: 0.7
         Assignee: Michael Dürig

Fixed at revision 1450828.
                
> Rename 'root' methods in NodeStore and NodeStoreBranch
> ------------------------------------------------------
>
>                 Key: OAK-609
>                 URL: https://issues.apache.org/jira/browse/OAK-609
>             Project: Jackrabbit Oak
>          Issue Type: Wish
>          Components: core
>            Reporter: angela
>            Assignee: Michael Dürig
>            Priority: Minor
>             Fix For: 0.7
>
>
> Currently we have some naming confusions in NodeStore and
> NodeStoreBranch and the various implementations.
> both interfaces define methods to access the node state associated with
> the root node with are called #getRoot() and in NodeStoreBranch also 
> #setRoot() while the corresponding fields are name 'head' or 'root'.
> since oak defines a Root interface which doesn't represent the root node state
> i would suggest to rename the methods mentioned above to something less confusing for example
> - getRootState
> - getHead
>  

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira