You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@shiro.apache.org by "Philippe Laflamme (JIRA)" <ji...@apache.org> on 2010/01/06 21:49:55 UTC

[jira] Created: (SHIRO-124) MethodInvocation is missing a getThis() (or equivalent) method

MethodInvocation is missing a getThis() (or equivalent) method
--------------------------------------------------------------

                 Key: SHIRO-124
                 URL: https://issues.apache.org/jira/browse/SHIRO-124
             Project: Shiro
          Issue Type: Bug
          Components: Specification API
            Reporter: Philippe Laflamme
             Fix For: 1.0


The current (r896125) revision of MethodInvocation does not expose a method for accessing the object on which the method is being invoked.

In the AOP world, I think this is the JoinPoint.getThis() method.

In any case, such a method is necessary to test permissions at the instance level (e.g.: "lightsaber:wield:blue", where "blue" is obtained from the instance on which the "wield()" method of the "Lightsaber" class is called.)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Assigned: (SHIRO-124) MethodInvocation is missing a getThis() (or equivalent) method

Posted by "Kalle Korhonen (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SHIRO-124?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Kalle Korhonen reassigned SHIRO-124:
------------------------------------

    Assignee: Kalle Korhonen

> MethodInvocation is missing a getThis() (or equivalent) method
> --------------------------------------------------------------
>
>                 Key: SHIRO-124
>                 URL: https://issues.apache.org/jira/browse/SHIRO-124
>             Project: Shiro
>          Issue Type: Bug
>          Components: Specification API
>            Reporter: Philippe Laflamme
>            Assignee: Kalle Korhonen
>             Fix For: 1.0.0
>
>
> The current (r896125) revision of MethodInvocation does not expose a method for accessing the object on which the method is being invoked.
> In the AOP world, I think this is the JoinPoint.getThis() method.
> In any case, such a method is necessary to test permissions at the instance level (e.g.: "lightsaber:wield:blue", where "blue" is obtained from the instance on which the "wield()" method of the "Lightsaber" class is called.)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Resolved: (SHIRO-124) MethodInvocation is missing a getThis() (or equivalent) method

Posted by "Kalle Korhonen (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SHIRO-124?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Kalle Korhonen resolved SHIRO-124.
----------------------------------

    Resolution: Fixed

Added getThis(). Both AspectJ and and aopalliance are using getThis() naming so I didn't see any need to use any different name for it


> MethodInvocation is missing a getThis() (or equivalent) method
> --------------------------------------------------------------
>
>                 Key: SHIRO-124
>                 URL: https://issues.apache.org/jira/browse/SHIRO-124
>             Project: Shiro
>          Issue Type: Bug
>          Components: Specification API
>            Reporter: Philippe Laflamme
>            Assignee: Kalle Korhonen
>             Fix For: 1.0.0
>
>
> The current (r896125) revision of MethodInvocation does not expose a method for accessing the object on which the method is being invoked.
> In the AOP world, I think this is the JoinPoint.getThis() method.
> In any case, such a method is necessary to test permissions at the instance level (e.g.: "lightsaber:wield:blue", where "blue" is obtained from the instance on which the "wield()" method of the "Lightsaber" class is called.)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Work logged: (SHIRO-124) MethodInvocation is missing a getThis() (or equivalent) method

Posted by "Kalle Korhonen (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SHIRO-124?page=com.atlassian.jira.plugin.system.issuetabpanels:worklog-tabpanel#action_11009 ]

Kalle Korhonen logged work on SHIRO-124:
----------------------------------------

                Author: Kalle Korhonen
            Created on: 21/Feb/10 06:21 AM
            Start Date: 21/Feb/10 06:21 AM
    Worklog Time Spent: 2h 

Issue Time Tracking
-------------------

            Time Spent: 2h
    Remaining Estimate: 0h

> MethodInvocation is missing a getThis() (or equivalent) method
> --------------------------------------------------------------
>
>                 Key: SHIRO-124
>                 URL: https://issues.apache.org/jira/browse/SHIRO-124
>             Project: Shiro
>          Issue Type: Bug
>          Components: Specification API
>            Reporter: Philippe Laflamme
>            Assignee: Kalle Korhonen
>             Fix For: 1.0.0
>
>          Time Spent: 2h
>  Remaining Estimate: 0h
>
> The current (r896125) revision of MethodInvocation does not expose a method for accessing the object on which the method is being invoked.
> In the AOP world, I think this is the JoinPoint.getThis() method.
> In any case, such a method is necessary to test permissions at the instance level (e.g.: "lightsaber:wield:blue", where "blue" is obtained from the instance on which the "wield()" method of the "Lightsaber" class is called.)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.