You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@geode.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2016/05/24 18:54:13 UTC

[jira] [Commented] (GEODE-1356) DataAsAddress should not be used in comments and strings

    [ https://issues.apache.org/jira/browse/GEODE-1356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15298704#comment-15298704 ] 

ASF subversion and git services commented on GEODE-1356:
--------------------------------------------------------

Commit 4d52260550c18e73382e3b337f464f290ffa4093 in incubator-geode's branch refs/heads/feature/GEODE-1153 from [~dschneider]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-geode.git;h=4d52260 ]

GEODE-1356: remove DataAsAddress references


> DataAsAddress should not be used in comments and strings
> --------------------------------------------------------
>
>                 Key: GEODE-1356
>                 URL: https://issues.apache.org/jira/browse/GEODE-1356
>             Project: Geode
>          Issue Type: Bug
>          Components: offheap
>            Reporter: Darrel Schneider
>            Assignee: Darrel Schneider
>            Priority: Trivial
>             Fix For: 1.0.0-incubating.M3
>
>
> The offheap implementation used to have a class named DataAsAddress.
> It no longer does. But we still have some places in the code that use this name.
> For example:
> UnsupportedOperationException("Did not expect DataAsAddress to be compressed");
> should be changed to:
> UnsupportedOperationException("Did not expect encoded address to be compressed");
> Another:
>         // else it is DataAsAddress. This code just returns it as prepared.
> should be:
>         // else it is has no refCount so just return it as prepared.
> Also the method: getSerializedLengthFromDataAsAddress should be renamed (or removed since it is deadcode).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)