You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "zhihao zhang (Jira)" <ji...@apache.org> on 2019/09/04 02:14:00 UTC

[jira] [Comment Edited] (FLINK-13926) `ProcessingTimeSessionWindows` and `EventTimeSessionWindows` should be generic

    [ https://issues.apache.org/jira/browse/FLINK-13926?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16921878#comment-16921878 ] 

zhihao zhang edited comment on FLINK-13926 at 9/4/19 2:13 AM:
--------------------------------------------------------------

The api usage between `EventTimeSessionWindows` and `DynamicEventTimeSessionWindows` are Incomprehensible, for example: 


{code:java}
DynamicEventTimeSessionWindows<String> assigner = DynamicEventTimeSessionWindows.withDynamicGap(extractor);
{code}

and 


{code:java}
EventTimeSessionWindows assigner = EventTimeSessionWindows.withDynamicGap(extractor);
{code}

one of them have a type parameter, but another one does not. it really makes me confused for the first time.




was (Author: izhangzhihao):
The api usage between `EventTimeSessionWindows` and `EventProcessingTimeSessionWindows` are Incomprehensible, for example: 


{code:java}
DynamicEventTimeSessionWindows<String> assigner = DynamicEventTimeSessionWindows.withDynamicGap(extractor);
{code}

and 


{code:java}
EventTimeSessionWindows assigner = EventTimeSessionWindows.withDynamicGap(extractor);
{code}

one of them have a type parameter, but another one does not. it really makes me confused for the first time.



> `ProcessingTimeSessionWindows` and `EventTimeSessionWindows` should be generic 
> -------------------------------------------------------------------------------
>
>                 Key: FLINK-13926
>                 URL: https://issues.apache.org/jira/browse/FLINK-13926
>             Project: Flink
>          Issue Type: Improvement
>          Components: API / DataStream
>    Affects Versions: 1.9.0
>            Reporter: zhihao zhang
>            Priority: Major
>              Labels: pull-request-available, windows
>             Fix For: 2.0.0
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> `ProcessingTimeSessionWindows` and `EventTimeSessionWindows` should be generic just like `DynamicEventTimeSessionWindows` and `DynamicProcessingTimeSessionWindows`.
> now:
>  
> {code:java}
> public class ProcessingTimeSessionWindows extends MergingWindowAssigner<Object, TimeWindow> {}
> {code}
> proposal:
>  
> {code:java}
> public class ProcessingTimeSessionWindows<T> extends MergingWindowAssigner<T, TimeWindow> {}
> {code}
> If this ticket is ok to go, I would like to take it.



--
This message was sent by Atlassian Jira
(v8.3.2#803003)