You are viewing a plain text version of this content. The canonical link for it is here.
Posted to announce@httpd.apache.org by Daniel Ruggeri <dr...@apache.org> on 2018/03/26 05:06:19 UTC
CVE-2018-1312: Weak Digest auth nonce generation in mod_auth_digest
CVE-2018-1312: Weak Digest auth nonce generation in mod_auth_digest
Severity: Low
Vendor: The Apache Software Foundation
Versions Affected:
httpd 2.2.0 to 2.4.29
Description:
When generating an HTTP Digest authentication challenge, the nonce
sent to prevent reply attacks was not correctly generated using a
pseudo-random seed. In a cluster of servers using a common Digest
authentication configuration, HTTP requests could be replayed across
servers by an attacker without detection.
Mitigation:
All httpd users should upgrade to 2.4.30 or later.
Credit:
The issue was discovered by Nicolas Daniels.
References:
https://httpd.apache.org/security/vulnerabilities_24.html