You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@cloudstack.apache.org by "Rohit Yadav (JIRA)" <ji...@apache.org> on 2013/01/04 08:12:12 UTC

[jira] [Commented] (CLOUDSTACK-212) Switch java package structure from com.cloud to org.apache

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-212?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13543661#comment-13543661 ] 

Rohit Yadav commented on CLOUDSTACK-212:
----------------------------------------

I moved a lot of classes org.apache.cloudstack from com.cloud in cloud-api in api_refactoring. To avoid merge conflicts and with people submitting their patches, what we should do is to switch to package name org.apache.cloudstack after the code freeze for 4.1.0, I think if we do that it would ensure minimal issues for any contributor (developer or committer). Discuss, or comment, maybe on ML? (Lastly, technical suggestion to avoid using Eclipse for that kind of rename refactoring as it tends to miss any text or non-java files, I would recommend IDEA CE which I'd used for work in api_refactoring.)
                
> Switch java package structure from com.cloud to org.apache
> ----------------------------------------------------------
>
>                 Key: CLOUDSTACK-212
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-212
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: pre-4.0.0
>            Reporter: Chip Childers
>            Priority: Minor
>             Fix For: 4.1.0
>
>
> Since the project has moved over to ASF, I'd like to suggest that we move from com.cloud to org.apache for the java package structure of our modules.
> If there is agreement, we can take this up after 4.0 is out the door.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira