You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by "Ted Yu (JIRA)" <ji...@apache.org> on 2013/04/30 11:04:16 UTC

[jira] [Created] (HBASE-8465) Improvement for snapshot restore

Ted Yu created HBASE-8465:
-----------------------------

             Summary: Improvement for snapshot restore
                 Key: HBASE-8465
                 URL: https://issues.apache.org/jira/browse/HBASE-8465
             Project: HBase
          Issue Type: Improvement
            Reporter: Ted Yu
            Assignee: Ted Yu


Below is an excerpt from snapshot restore javadoc:
{code}
   * Restore the specified snapshot on the original table. (The table must be disabled)
   * Before restoring the table, a new snapshot with the current table state is created.
   * In case of failure, the table will be rolled back to the its original state.
{code}
We can improve the handling of rollbackSnapshot in two ways:

1. give better name to the rollbackSnapshot (adding '-for-rollback-'). Currently the name is of the form:
    String rollbackSnapshot = snapshotName + "-" + EnvironmentEdgeManager.currentTimeMillis();

2. drop rollbackSnapshot at the end of restoreSnapshot() if the restore is successful. We can introduce new config param, named 'hbase.snapshot.restore.drop.rollback', to keep compatibility with current behavior.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira